none
BizTalk Publish as WCF: HTTP Error 403.4 - Forbidden RRS feed

  • Question

  • I used BizTalk 2010.

    I publish BizTalk application as WCF Service.

    I open website by IE 8 using https in url. The website says (I think this is the page to download wsdl):


    BizTalkServiceInstance Service

    You have created a service.

    To test this service, you will need to create a client and use it to call the service. You can do this using the svcutil.exe tool from the command line with the following syntax:

    svcutil.exe http://...svc?wsdl


    I click on link http://...svc?wsdl

    Then I get: 

    HTTP Error 403.4 - Forbidden
    The page you are trying to access is secured with Secure Sockets Layer (SSL).

    I notice the url in address bar is in http.

    I tried changing url to https (https://...svc?wsdl). It gives me the page BizTalkServiceInstance Service  for downloading wsdl.

    How to solve Error 403.4 to get the BizTalk WCF wsdl?

    Please help. Thanks.

     

    Friday, April 21, 2017 4:47 AM

All replies

  • Hi,

    Can you try to disable the SSL certification authentication from IIS .

    • Open IIS Manager
    • Click on your website or virtual directory 
    • Click on the "SSL Settings" in the "IIS" section
    • Uncheck "Require SSL"

    Thanks

    Abhishek


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply


    Friday, April 21, 2017 5:22 AM