locked
Microsoft SQL Server Login Error RRS feed

  • Question

  • I'm not use to SQL, i've just installed it and when i'm trying to connect to it with every thing in default configuration i got this popup :

    Connection failed:
    SQLState '08001'
    SQL Server Error: -1
    [Microsoft][SQL Native Client] SQL Network Interfaces: Error Locating Server/Instance Specified [xFFFFFFFF]
    Connection failed:
    SQLState '08001'
    SQL Server Error: -1
    [Microsoft][SQL Native Client] An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default setting SQL Server does not allow remote connections
    Connection failed:
    SQLState 'S1T00'
    SQL Server Error: 0
    [Microsoft][SQL Native Client] Login timeout expired

    I really don't know what to do, i've reinstall it, i have restarted server....

    I'm on windows XP.
    Tuesday, August 25, 2009 1:47 PM

Answers

  • This problem may occur when SQL Server 2005 is not configured to accept remote connections. By default, SQL Server 2005 Express Edition and SQL Server 2005 Developer Edition do not allow remote connections.  To configure SQL Server 2005 to allow remote connections, complete all the following steps:

    ·         Enable remote connections on the instance of SQL Server

    ·         Turn on the SQL Server Browser service.

    ·         Configure the firewall to allow network traffic that is related to SQL Server and to the SQL Server Browser service.

    For more information, see here: http://support.microsoft.com/default.aspx?scid=kb;EN-US;914277


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Tuesday, September 1, 2009 2:43 AM

All replies

  • Hi,
     1) Can u pls make sure that sql services are running by looking into sql server confirguration manager. If not pls start it.
    2) Pls go to run and sqlcmd (shoukd be admin iD)
    sqlcmd -S <ComputerName>
    sqlcmd -S .\<InstanceName>
    If u know "sa" password , try to login with sql authenication
    Tuesday, August 25, 2009 3:33 PM
  • Hi,
     R u using sqlwb(management studio) to connect, then in server name box type . (dot) if u don't give any specfic name for the sql instance durning installation.
    Tuesday, August 25, 2009 3:37 PM
  • This problem may occur when SQL Server 2005 is not configured to accept remote connections. By default, SQL Server 2005 Express Edition and SQL Server 2005 Developer Edition do not allow remote connections.  To configure SQL Server 2005 to allow remote connections, complete all the following steps:

    ·         Enable remote connections on the instance of SQL Server

    ·         Turn on the SQL Server Browser service.

    ·         Configure the firewall to allow network traffic that is related to SQL Server and to the SQL Server Browser service.

    For more information, see here: http://support.microsoft.com/default.aspx?scid=kb;EN-US;914277


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Tuesday, September 1, 2009 2:43 AM