locked
Web Access Control tool in MS Web Access RRS feed

  • Question

  • Is there a guide or reference regarding the Web Access Control to use in views on MS Web Access, I am not able to make it work to open web addresses. If there is any guide or advice how to configure it, I would appreciate.

    What I want the web access part to do is open a document library so users can upload files on a Sharepoint library, copy the links and paste it on my MS Web app record, that way they can upload their files and copy just the hyperlink instead of having the image on the DB.

    Thanks in advance for your help

    Wednesday, November 2, 2016 4:19 PM

All replies

  • Hi WilReyes,

    >> What I want the web access part to do is open a document library so users can upload files on a Sharepoint library,

    Do you mean you want to show sharepoint url in WebBrowser control in Access web app? If so, it is impossible. It is limited by sharepoint site. If you put a url like “https://www.bing.com/”, you will find it is loaded correctly. If you put sharepoint site in the url, after you open your web app, you will get similar error “Refused to display 'https://xx/SitePages/Home.aspx' in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN'.” if you press F12 to turn to debug mode. This error indicate that SharePoint site is not allowed to embed in a frame.

    For a workaround, I would suggest you add a Hyperlink control with sharepoint url, you could open the sharepoint site by clicking this Hyperlink control.

    If this is a new feature you want to include in the future, I would suggest you submit a feedback.

    http://access.uservoice.com/

    Best Regards,

    Edward


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, November 3, 2016 6:16 AM