locked
Visual Studio community 2015 browser connect not working always shows 0 connections RRS feed

  • Question

  • User320571768 posted

    I just started using Visual Studio and tried to duplicate a tutorial by Bob Tabor. Trying to display a HTML file using Browser connect.

    here's what I'm doing:

    1) new project
    2) Web ASP.NET Web Application
    3) Empty template
    4) add new item --> html page
    5) add 'test" to to title and body
    6) try to view in browser - get http://localhost:51962/HtmlPage1.html
       with waiting for localhost to respond
    

    browser dashboard says no connections

    added to web.config:

    <system.webServer>    
    <handlers>
      <add name="Browser Link for HTML" path="*.html" verb="*" 
           type="System.Web.StaticFileHandler, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" 
           resourceType="File" preCondition="integratedMode" />
    </handlers>
    </system.webServer>
    

    but nothing seems to work. could someone provide the proper steps?

    Saturday, December 5, 2015 12:49 AM

All replies

  • User-166373564 posted

    Hi,

    Here are some suggestions:

    Cleaning and rebuilding your current Project (Right-click > Clean, Right-click Rebuild respective) and see if that makes any difference at all. 

    Stop your existing application and ensure that you don't have any additional IIS processes or instances of your local Web Server running.

    If these issues are still persisting after the above steps, try restarting Visual Studio (and even your local machine)

    If it still has same issue, please let me know.

    Regards,

    Angie

    Tuesday, December 8, 2015 12:01 PM