none
BiizTalk 2013 and EDI Message Invalid character in data element RRS feed

  • Question

  • Hi:

    Background: I have a Vendor sending us EDI 856 (Advance Shipping Notice). We are using EDI X12 and BizTalk 2013. In the Parties Agreement we use ISA11 = U-US EDI Community of ASC X12. The vendor is sending 'U' in ISA11.

    Error:

    At the beginning of EDI Schema import, during EDI audit, we get the following error messages, repeated a few time.

    Error: 1 (Field level error)

                SegmentID: LIN

                Position in TS: 18

                Data Element ID: LIN09

                Position in Segment: 9

                Data Value:

                6: Invalid character in data element

    Error: 2 (Field level error)

                SegmentID: PID

                Position in TS: 20

                Data Element ID: PID05

                Position in Segment: 5

                Data Value:

                6: Invalid character in data element

    Root Cause: In all the error cases the data fields contain “Ü” (U with two dots above it). German character.

    Question: What is the best way to deal with the issue or replace “Ü” (U with two dots above it) characters?

    Looking forward to your reply.

    Regards, Toraj


    Toraj toraj.khavari@a-dec.com

    Tuesday, April 21, 2015 3:03 PM

Answers

  • I edited the source file and saved it as UTF-8. It seems, it resolved the issue.

    Very cool.

    Toraj


    Toraj toraj.khavari@a-dec.com

    • Marked as answer by Toraj Khavari Tuesday, April 21, 2015 3:31 PM
    Tuesday, April 21, 2015 3:29 PM

All replies

  • I edited the source file and saved it as UTF-8. It seems, it resolved the issue.

    Very cool.

    Toraj


    Toraj toraj.khavari@a-dec.com

    • Marked as answer by Toraj Khavari Tuesday, April 21, 2015 3:31 PM
    Tuesday, April 21, 2015 3:29 PM
  • I edited the source file and saved it as UTF-8. It seems, it resolved the issue.

    Very cool.

    Toraj


    Toraj toraj.khavari@a-dec.com

    Glad that you have solved this issue by yourself, and thanks for sharing your solution to us.

    Best regards,

    Angie


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, April 22, 2015 9:23 AM