none
highlighting words in a text to speech application for Word 2007 has a problem with text written as a link RRS feed

  • Question

  • I developed a text to speech application using Visual Basic 2010 by creating an add-in for Word 2007. The application worked fine. When I tried to add highlighting to spoken words using the SpeekEventArgs of the SpeechSynthizer, It also worked fine except when reading the e-mail address. The highlight is lagging behind the spoken words because the highlight is done twice. ( so the spoken words and the highlighting are out of cynic) . I noticed that when the add-in is reading my résumé which included my e-mail address  . I  tried o read the same document using a third-party add-in for Word - namely WordTalk. The same problem persisted. I think this is a bug. Is there any workaround for this problem ?? Actually this behavior  happens with any text that is written as a link

    Thanks

    Abdel Galil Hussein

    e-mail :abdelgalilh@gmail.com

    Tuesday, July 30, 2013 9:03 PM

All replies

  • I developed a text to speech application using Visual Basic 2010 by creating an add-in for Word 2007. The application worked fine. When I tried to add highlighting to spoken words using the SpeekEventArgs of the SpeechSynthizer, It also worked fine except when reading the e-mail address. The highlight is lagging behind the spoken words because the highlight is done twice. ( so the spoken words and the highlighting are out of cynic) . I noticed that when the add-in is reading my résumé which included my e-mail address  . I  tried o read the same document using a third-party add-in for Word - namely WordTalk. The same problem persisted. I think this is a bug. Is there any workaround for this problem ?? Actually this behavior  happens with any text that is written as a link

    Thanks

    Abdel Galil Hussein

    e-mail :abdelgalilh@gmail.com

    Tuesday, July 30, 2013 8:58 PM