locked
IIS 7, Windows Server 2008, HTTP Error 404.2 - Not Found RRS feed

  • Question

  • User-295493466 posted
    I am getting this error: "The page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server." This only seems to happen when I am targeting the .net 40 framework. I am just running a simple hello world test app and so there is no cgi or Isapi application running. Any ideas on how to tackle this? Regards, Thomas
    Wednesday, August 3, 2011 2:42 PM

Answers

  • User1073881637 posted
    Make sure the 4.0 items listed in the cgi / isapi restrictions are enabled (allowed)
    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, August 3, 2011 10:37 PM

All replies

  • User1073881637 posted
    Make sure the 4.0 items listed in the cgi / isapi restrictions are enabled (allowed)
    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, August 3, 2011 10:37 PM
  • User-295493466 posted
    Make sure the 4.0 items listed in the cgi / isapi restrictions are enabled (allowed)
    I am sorry, but I am very new to iis7. Can you explain how to do this?
    Wednesday, August 3, 2011 11:10 PM
  • User-295493466 posted
    Thanks Steve, I figured it out and you got me going in the right direction. - Opened IIS - Clicked on the Servername - Went to the IIS group and double clicked on cgi & Isapi restrictions - Selected the desired framework and clicked allow in the right pane Thanks a ton!
    Friday, August 5, 2011 1:58 PM
  • User-1672167363 posted

    Hi,

    To add to Steves post start here http://www.iis.net/ConfigReference/system.webServer 

        then Expand to CGI or ISAPI

      and Magnify the image or look at the list that is the section to use in IIS Manager.

    It takes awhile getting used to finding things in IIS Manager or the IIS Reference.

    Martin

       

    Friday, August 5, 2011 2:11 PM
  • User2084661313 posted

     Hello,

    Please refer the URL http://mywindowsblog.com/?p=587 in order to solve your issue .

     

    Thursday, January 26, 2012 2:21 AM