none
EDIFACT white space before segment terminator RRS feed

  • Question

  • Hi all,

    I process and EDIFACT INVOIC D96A document like this and i receive "Invalid character(s) found in data element" error in C27304 data element because there is a white space before ' char.

    Can I bypass this error via Party configuration? I receive the same error in Biz 2006 R2 and in Biz 2010 beta.

    Thanks!

    UNA:+.? '
    UNB+UNOC:3+8223338042261:14+BR030111:ZZ+100701:1905+88'
    UNH+3586+INVOIC:D:96A:UN:EAN008'
    ....
    ..
    IMD+F+DSC+:::MAGMA K LOW Factor '
    ..
    
    
    Wednesday, July 7, 2010 2:39 PM

Answers

  • Hi,

        I think by this sentence he is refering UNA segment:

    UNA:+.? '


    And this makes space a delimiter. And where ever space will come Edi- pipeline will treat as delimiter not as payload. And if you see in the line

    IMD+F+DSC+:::MAGMA K LOW Factor '

     

    There are spaces in between words. So in these cases edi pipeline will throw error.

     

     

    Thanks

    Gyan


    If this answers your question, please mark it as "Answered".
    Thursday, July 8, 2010 1:35 PM

All replies

  • Hi,

    If you partner does not have control over these validation items you can skip this validation by using party settings.

    Go to EDIfact Properties --> Party As Interchange Sender --> ACK Generation and Valication --> Documet Validation properties --> Check Allow leading and trailing zeroes and spaces.


    Best Regards, Vishnu
    Wednesday, July 7, 2010 2:50 PM
  • it works on BizTalk 2006 R2 but it doesn't works on BizTalk 2010 beta.
    Party setting was changed and seems that it doesn't accept any changes in validation section.

    Many thanks

    Wednesday, July 7, 2010 3:47 PM
  • OK, I havent used 2010 Beta yet so I can not comment on that. As for as 2006 R2 goes it should work and it is working as well.
    Best Regards, Vishnu
    Wednesday, July 7, 2010 3:50 PM
  • Hi Massimox,

                      Where are you setting allow leading and trailing zerows and spaces? It works in the same way as BTS06R2.

     

    And what vishnu says about leading and trailing spaces will not solve your problem because you do not have only leading or trailing spaces but you have spaces in between also. And this setting is only for leading and trailing zeros and spaces.

     

    For your scenario :

    It's wrong according to EDIFACT standards . Because standards says you should not use delimiters as payload. But you can mitigate this problem using a custom pipeline component. Before dropping this file to edi receive pipeline create a component that replaces Space in UNA segment to some other characters.

     

     

    Thanks

    Gyan


    If this answers your question, please mark it as "Answered".
    Thursday, July 8, 2010 12:52 PM
  • Hi Gyan,

    Infact he is saying that white spaces are at the end of the segment. Please read because there is a white space before ' char. 

    the char {'} comes at the end of the segment.  Thus spaces are only at the end and not in between.

    I beleive in this case the setting should work.

    If he is receiving a message as you have mentioned then ofcourse that will be invalid EDI. Please correct me if I misunderstood the problem.


    Best Regards, Vishnu
    Thursday, July 8, 2010 1:27 PM
  • Hi,

        I think by this sentence he is refering UNA segment:

    UNA:+.? '


    And this makes space a delimiter. And where ever space will come Edi- pipeline will treat as delimiter not as payload. And if you see in the line

    IMD+F+DSC+:::MAGMA K LOW Factor '

     

    There are spaces in between words. So in these cases edi pipeline will throw error.

     

     

    Thanks

    Gyan


    If this answers your question, please mark it as "Answered".
    Thursday, July 8, 2010 1:35 PM
  • I agree. Space will become a Repitition separator [delimeter] as UNA5 is space. And due to this reason he will get error whenever space will be encountered in the payload.
    Best Regards, Vishnu
    Thursday, July 8, 2010 2:01 PM