none
Deploying Windows 8.1 app from Windows 10 computer

    Question

  • Hi all,

    I have a Windows 8.1 app in the store that I recently updated from my Windows 10 computer (running VS 2015 with Windows 8.1 support installed) for the first time.

    The update for the phone app worked fine, but the Windows 8.1 tablet app crashes on startup on Windows 8.1 computers, but runs fine on Windows 10 computers.

    The binaries in the store are Windows 8.1 binaries and obviously passed certification. 

    Has anyone else run into this?

    Thanks for any help you can give.  This is obviously a little bit time sensitive.

    Greg

    Wednesday, August 12, 2015 5:08 PM

All replies

  • Hello Gerg_Dickie,

    Since this is related to publishing store app I will alert moderator to move this thread to Publishing Windows Store apps forum.

    With Regards,

    Krunal Parekh


    Thanks MSDN Community Support Please remember to Mark as Answer the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.


    Thursday, August 13, 2015 8:14 AM
  • Hi Greg,

    Sorry to hear of the trouble. If you have not already, can you submit another update of the app and be sure to increment the version number higher than before? If the issue persists, please open a support ticket with us to investigate further.

    Thanks,

    Jonathan


    Windows and Windows Phone Dev Center Support

    Office Store Developer Support

    Send us your feedback about the Windows Platform

    Friday, August 14, 2015 2:58 AM
    Moderator
  • Hi Jonathan,

    What I ended up doing since it was fairly time critical was to spin up my old Windows 8.1 VM and do the build/publish from there.  That appears to have solved the problem.

    Given the number of users that we have for the app I didn't want to try to publish again from the Windows 10 computer and have it crash on start up for them a second time.

    Before I did the initial publish from the Windows 10 VM I had incremented the version number from 1.1.15.x to 1.1.16.0, the latest working version that I deployed is 1.1.16.1.

    I am willing to work with the support team to try to resolve the problem as long as it doesn't affect the users of the application.  I'm wondering if it might be possible to deploy the app under a different name and test that way.

    Greg

    • Proposed as answer by Krunal Parekh Wednesday, August 26, 2015 6:12 AM
    Friday, August 14, 2015 1:36 PM