locked
Master Page feature is missing under Look and Feel section RRS feed

  • Question

  • Hi,

    In this link http://www.toddbaginski.com/blog/images/www_toddbaginski_com/blog/WindowsLiveWriter/HOWTOCreateacustomthemeforSharePoint2010_B430/site%20administration%20pages_2.png, I saw Master Page feature under Look and Feel section. But in my SP2010 sites, it is missing. Is there any idea how to solve it? Thanks for your attention and help!
    Thursday, February 25, 2010 8:22 AM

Answers

All replies

  • Hi

    You can only view this at site collection level.
    Please make sure you have the SharePoint Server Publishing Infrastructure feature enabled.
    Thursday, February 25, 2010 8:55 AM
  • Thanks for your quick reply. I have already enabled SharePoint Server Publishing Infrastructure feature in site collection level. :(
    Thursday, February 25, 2010 9:02 AM
  • Can you try with the direct link:

    http://yourserver/_Layouts/ChangeSiteMasterPage.aspx
    Thursday, February 25, 2010 9:19 AM
  • I tried it. I guess I missed out to activate the features in central administration. When I tried to activate it in central administration, I got the following error message
    Publishing sites and features cannot be activated in the Central Administration Web Application

    Is there any idea for that? Thanks
    Thursday, February 25, 2010 9:38 AM
  • Hello,

    Now I can try the direct link. But I still don't see the Master Page link under Look and Feel header. :( Please share your knowledge if you know how to tackle it. Thanks a lot for your attention and time.
    Thursday, February 25, 2010 9:59 AM
  • Hi

    Is you master page ghosted or unghosted ? (ie is it on the filestore or in the Content Database)

    If it is on the filestore then I dont think you can see it. (ie you have deployed it using a .wsp file)

    Regards

    Nigel
    Monday, March 1, 2010 12:06 PM
  • Hi Nigel,

    I just tested to modify the copied file of v4.master so I guess my master file is unghosted. But my knowledge is that we should see Master Page link under Look and Feel header in the setting page of Site Collection after activating Publishing Infrastructure feature. Seeing the link is not related to what kind of customized master files are created. But I can access the direct link http://myservername/_Layouts/ChangeSiteMasterPage.aspx. Another issue is that when I tried to activate this feature in central administration, I got the following error message
                 Publishing sites and features cannot be activated in the Central Administration Web Application
    :( Please share your knowledge if you know how to solve it. Thanks a lot for your attention and time.
    Tuesday, March 2, 2010 1:43 AM
  • Hi

    Central Admin is normally security trimmed - are you logged on as the farm administrator ?

    Regards

    Nigel
    Tuesday, March 2, 2010 6:58 AM
  • Yes, I logged on as the farm administrator. I can activate some features except Publishing Infrastructure feature. Thanks for your contribution.

    Tuesday, March 2, 2010 7:06 AM
  • You are trying to activate the Publishing Feature in the SharePoint Central Administration site which is not allowed.

    Create a new Web Application, then a Site Collection and then activate the Publishing Feature. If you already have a web application and site collection, you can activate in that too.

    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Tuesday, March 2, 2010 9:26 AM
  • Thanks a lot for your reply. I have already activated it in the site collection of a web application. So I can access the direct link http://myservername/_Layouts/ChangeSiteMasterPage.aspx.But Master Page link is missing under Look and Feel section of the setting page of site collection. :(
    Tuesday, March 2, 2010 9:32 AM
  • Hi ncth,

    You would also need to activate SharePoint Server Publishing feature located in Site Actions > Site Settings > Manage Site Feature .

    The Master Page link will appear when you have these 2 features activated

    1. SharePoint Server Publishing Infrastructure (under Site collection features)
    2. SharePoint Server Publishing (under Manage Site Feature)
    • Edited by JeeWong Friday, April 30, 2010 12:08 AM typo
    • Proposed as answer by Debangshu Roy Friday, April 30, 2010 11:00 AM
    Friday, April 30, 2010 12:08 AM
  • Hi,

    In this link http://www.toddbaginski.com/blog/images/www_toddbaginski_com/blog/WindowsLiveWriter/HOWTOCreateacustomthemeforSharePoint2010_B430/site%20administration%20pages_2.png, I saw Master Page feature under Look and Feel section. But in my SP2010 sites, it is missing. Is there any idea how to solve it? Thanks for your attention and help!

    I'm having a similar issue that is not related to the publishing infrastructure feature. The problem, in my case, is that some/most of the pages in the central admin are using the v3 ui instead of the v4 ui. The v4 ui has the master page link under look and feel whereas the v3 ui does not. I applied a custom master page to both the site and the system and I started seeing the v3 ui in the central admin. I changed the master page back to the nightandday.master but it seems to have no effect on the ui version. I suspect that ncth is having a similar issue.
    Tuesday, December 14, 2010 7:21 PM
  • Hi

    Have you run visual upgrade ?

    Regards

    Nigel

    Wednesday, December 15, 2010 8:57 AM
  • Go to http://[CentralAdministrationServer]/_admin/enablingfeatures.aspx, check the Enable all sites in this installation to use the following set of features make sure that SharePoint Server Enterprise Features is shown as an item available to enable.
    Sunday, March 27, 2011 12:55 PM
  • Thanks JeeWong,

    This solved my problem.  Its important  that you enable publishing in both the place.

    http://oconndav.com/?p=9




    Tuesday, June 14, 2011 12:42 PM
  • Change masterpage link does not visible if you not activate the following features.

    1. Publising feature on site collection level.

    2. publising feature on web level.

    3.wiki home page feature on web level ( which is dependent on webPageLibrary feature so you have to activate frist web page library feature

    all the above you can do by code on feature receiver.

    const

     

    string masterPageName = "usaa_blue_teal.master";

    //change master page name

     

    Guid gidSiteCollectionPublishingfeature = new Guid("F6924D36-2FA8-4f0b-B16D-06B7250180FA");

    // feature id of Publishing feature web scope

     

    Guid gidWebPublishingfeature = new Guid("22A9EF51-737B-4ff2-9346-694633FE4416");

    // feature id of Publishing feature web scope

     

     

    //for activate the WikiHomePage feature on web level,frist we need to activate the webPageLibrary Feture on web level

     

    // befause WikiHomePage Feture has dependency on WebPageLibrary. so activating borth the feature.

     

    Guid gidWebPageLibraryfeature = new Guid("00BFEA71-C796-4402-9F2F-0EB9A6E71B18");

    // feature id of WebPageLibrary feature web scope

     

    Guid gidWebWikiHomePagefeature = new Guid("00BFEA71-D8FE-4FEC-8DAD-01C19A6E4053");// feature id of WikiHomePage feature web scope

     

     

    SPSecurity.RunWithElevatedPrivileges(delegate

    ()

    {

     

     

    SPSite curSite = (SPSite

    )properties.Feature.Parent;

     

     

    if (curSite == null

    )

     

     

    return

    ;

     

     

    SPWeb

    curWeb = curSite.RootWeb;

    curSite.AllowUnsafeUpdates =

     

    true

    ;

    curWeb.AllowUnsafeUpdates =

     

    true

    ;

     

     

    SPSite site = properties.Feature.Parent as SPSite

    ;

     

     

    SPWeb

    rootweb = site.RootWeb;

     

     

    SPFeatureProperty url = properties.Definition.Properties["SearchUrl"

    ];

     

     

    if (site == null

    )

    {

     

     

    throw new SPException("Feature must be activated at site scope"

    );

    }

    rootweb.AllProperties[

     

    "SRCH_ENH_FTR_URL"] = "/Searchcenter/Pages"

    ;

    rootweb.AllProperties[

     

    "SRCH_SITE_DROPDOWN_MODE"] = "ShowDD"

    ;

    rootweb.Update();

     

     

    //activating site feature first

     

     

     

    if (curSite.Features[gidSiteCollectionPublishingfeature] == null

    )

    {

    curSite.Features.Add(gidSiteCollectionPublishingfeature,

     

    true

    );

    logger.TraceToDeveloper(

     

    "Activated site Collection Publishing Infra. Feature fro USAA Master Page " + methodBase.Name, EventLogEventId, TraceSeverity

    .Medium, areaCategory);

    }

     

     

    //activating web feature

     

     

    SPWebCollection

    AllWebs = curSite.AllWebs;

     

     

    foreach (SPWeb web in

    AllWebs)

    {

    logger.TraceToDeveloper(

     

    "Entering for Activating the web scopre Feature for USAA Master Page " + methodBase.Name, EventLogEventId, TraceSeverity

    .Medium, areaCategory);

     

     

    if (web.Features[gidWebPublishingfeature] == null

    )

    {

    web.Features.Add(gidWebPublishingfeature,

     

    true);

    //Publishing Feature

    }

     

     

    if (web.Features[gidWebPageLibraryfeature] == null

    )

    {

    web.Features.Add(gidWebPageLibraryfeature,

     

    true);

    //webPageLibrary Feature

    }

     

     

    if (web.Features[gidWebWikiHomePagefeature] == null

    )

    {

    web.Features.Add(gidWebWikiHomePagefeature,

     

    true);

    //WikiHomePage Feature

    }

    logger.TraceToDeveloper(

     

    "leaving after Activating the web scopre Feature for USAA Master Page " + methodBase.Name, EventLogEventId, TraceSeverity

    .Medium, areaCategory);

    }

     

     

     

     

    Uri masterUri = new Uri(curWeb.Url + "/_catalogs/masterpage/USAA_MasterPageAndPageLayout/" + masterPageName);

    //it can be "usaa_tan_team.master" or "usaa_blue_gray_team.master" as well

     

     

    //Master page used by all forms and pages on the site that are Not publishing pages

    curWeb.MasterUrl =

     

    SPEncode

    .UrlDecodeAsUrl(masterUri.AbsolutePath);

     

     

    // Master page used by all publishing pages on the site

    curWeb.CustomMasterUrl =

     

    SPEncode

    .UrlDecodeAsUrl(masterUri.AbsolutePath);

    curWeb.Update();

    curWeb.AllowUnsafeUpdates =

     

    false

    ;

    curSite.AllowUnsafeUpdates =

     

    false

    ;

    logger.TraceToDeveloper(

     

    "Leaving" + methodBase.Name, EventLogEventId, TraceSeverity

    .Medium, areaCategory);

     

     

    //curWeb.Dispose();

     

     

    //curWeb.Close();

    });

     
    Krishana Kumar
    Wednesday, August 10, 2011 6:18 AM
  • Yes JeeWong,

    You are right, we need to activate publishing feature both on site collection level and on site level.

    Thanks.

    Friday, August 10, 2012 2:43 PM