locked
Login failed for user 'sa' .The user is not assosiated with a trusted SQL Server Connection. RRS feed

  • Question

  • Dear Friends,

                       I have downloaded a project from

    http://www.c-sharpcorner.com/Tutorials/Building3TierAppPA.asp

     

     ,which is an example of 3 tier architecture.

    To run this project the author has suggested to change the 'value' in <appsettings> of webconfig file.

    previously it was

     <add key="SqlConnect" value="ABRAHAMOS;database=TimeManagement;uid=sa;pwd=moses;" />

    I changed it to

     <add key="SqlConnect" value="server=ABC-314FF72122C\SQLEXPRESS;database=TimeManagement;uid=sa;pwd=moses" />

    as 'ABC-314FF72122C\SQLEXPRESS'  is the server name of my sqlserver 2005.

    when i run the project and try to enter something from a page then error occur as  'Login failed for user 'sa' .The user is not assosiated with a trusted SQL Server Connection.'

    what could be the possible reason?????????

     

    Till now I have tried following things:

    1. I kept the pwd value blank and tried to run-------- then also the same problem

    2.   I kept the pwd value .(dot) and tried to run-------- then also the same problem

    3.   I tried to change the password of 'sa' login from management studio but failed.

     

    I would like to know the following things:

    1. Solution for this problem so that the downloaded project runs.

    2. how do I change the password of 'sa' login using  Management Studio.

    3. how do I know which is     the present pasword of  login 'sa'

    Tuesday, May 17, 2011 8:53 PM

Answers

  • Your SQL Server is configured only for windows authentication mode, change it to mixed mode and then restart sql services. Once it's done you can use SQL authentication. To change the authentication mode refer http://msdn.microsoft.com/en-us/library/ms188670.aspx KB article
    Vidhya Sagar. Mark as Answer if it helps!
    • Proposed as answer by RamJaddu Wednesday, May 18, 2011 6:50 PM
    • Marked as answer by WeiLin Qiao Thursday, May 26, 2011 8:36 AM
    Wednesday, May 18, 2011 2:47 AM
  • you must change SQL Server configuration from windows authentication to mixed mode. 

    sql 2008 sa account would be disabled by default if that is the case please enable it


    http://uk.linkedin.com/in/ramjaddu
    • Marked as answer by WeiLin Qiao Thursday, May 26, 2011 8:36 AM
    Wednesday, May 18, 2011 6:53 PM

All replies

  • Your SQL Server is configured only for windows authentication mode, change it to mixed mode and then restart sql services. Once it's done you can use SQL authentication. To change the authentication mode refer http://msdn.microsoft.com/en-us/library/ms188670.aspx KB article
    Vidhya Sagar. Mark as Answer if it helps!
    • Proposed as answer by RamJaddu Wednesday, May 18, 2011 6:50 PM
    • Marked as answer by WeiLin Qiao Thursday, May 26, 2011 8:36 AM
    Wednesday, May 18, 2011 2:47 AM
  • you must change SQL Server configuration from windows authentication to mixed mode. 

    sql 2008 sa account would be disabled by default if that is the case please enable it


    http://uk.linkedin.com/in/ramjaddu
    • Marked as answer by WeiLin Qiao Thursday, May 26, 2011 8:36 AM
    Wednesday, May 18, 2011 6:53 PM