none
Possible solution to .Net Framework 4.0 instrallation errors on Windows 7 RRS feed

  • General discussion

  •  

    I had a lot of trouble with Dot Net 4 Installation on Windows 7.

    After over 2 weeks of trying all sorts of solutions from many helpful people, I spent about 10 hours and figured this out on my own.

    Please tell me if it works for you. Full tread with my attempted solutions here:

    Error installing .NET 4.0 Framework on Windows 7 Ultimate x64

    This is what finally worked for me.

    I went to "C:\Windows\Microsoft.NET" there is a directory called "assembly".

    I looked in the directory and found some subdirectories with lots of old dot net 4 files. I renamed the directory assembly2 and tried to install Dot Net 4 and it worked!!!!

    (You can't delete the assembly directory unless you take ownership of it but you can rename it.)

    It seems that something was in the old "assembly" directory.

    Everything is working fine now. How come that is not mentioned anywhere? I bet many people are having this problem.

    Ira

    • Edited by irarab Sunday, November 27, 2011 1:45 PM
    Sunday, November 27, 2011 1:40 PM