locked
About “Unable to display virtual machine sizes” RRS feed

  • Question

  • Hi,

    Following the step to create a VM in azure stack TP2, I got an error "Unable to display virtual machine sizes" in step 2 "Choose virtual machine size".

    I also see there is already a known issue in troubleshooting of https://azure.microsoft.com/en-us/documentation/articles/azure-stack-troubleshooting/ as follows:

    "When using the portal to create VMs on Azure Stack environments with identity in ‘Azure - China’, you will not see VM sizes available to select in the Size step of VM deployment and will be unable to continue deployment."

       So my question is this issue is fixed or not? How to create a VM with identity in 'Azure -China' ?

    Thanks.


    • Edited by ddebby Tuesday, October 25, 2016 3:39 AM
    Tuesday, October 25, 2016 3:38 AM

Answers

All replies

  • Hello,

    Thank you for posting here!

    Please send us an email at ascustfeedback@microsoft.com, and we will set up a workspace where you can upload the logs for us to analyze.

    Regards,

    Pradeep

    Tuesday, October 25, 2016 4:12 PM
  • This issue still exists as detailed in the FAQs.

    Thanks


    Daniel.

    Tuesday, October 25, 2016 6:37 PM
  • Hi Pradeep, i am facing the same error while creating new VM "Unable to display virtual machine size", referring to troubleshooting guide selecting the HDD instead of SSD unfortunately same error. Any solution for this issue ?

    DKP

    Wednesday, October 26, 2016 1:21 PM
  • So is there any way to provision a VM with my ‘Azure - China’ account ?
    Thursday, October 27, 2016 5:14 AM
  • Hi,

    If you are trying to deploy with Mooncake (China Azure) AAD, please use this work-around:

    In host machine, edit \\mas-xrp01\c$\Program Files\Microsoft Tenant Extension\Web.config.

    About line 63: <add key="Microsoft.Portal.Security.AzureActiveDirectory.AadAuthenticationConfiguration.Authority" value="https://login.windows.net/" />The value should be updated to https://login.chinacloudapi.cn/

    Regards,

    Pradeep


    Thursday, October 27, 2016 3:50 PM