locked
ReportViewer.msi couldn't be verified RRS feed

  • Question

  • Hi,

    I'm using Visual Studio Setup Project plugin for Visual Studio 2013 in order to deploy a WPF application.

    I had Report Viewer 2012 as a preriquist and I have no problem on Windows 7 SP1, Windows 8 and Windows 8.1.

    I have a problem when installing with local embeded ReportViewwer msi with Windows Vista SP2. When Copying file, the setup fail to verify ReportViewer.msi. When I look to the properties of the msi file, the signature is not valid and has no date and time.

    How to fix this ?

    Thank you


    Friday, February 20, 2015 10:18 AM

Answers

  • Hi Youjun,

    Thank you for your answer but why does ReportViewer.msi deployment can't be automatic in Vista ?

    I managed to do it this week with a batch file in a .sfx package.

    Best regards,

    Monday, February 23, 2015 8:10 AM

All replies

  • Hi Benjamin DAGUÉ,

    Vista will never install ReportViewer.msi automatically. You always have to manually install it.

    http://www.microsoft.com/en-gb/download/details.aspx?id=35747

    If you have any other concern regarding this issue, please feel free to let me know.

    Best regards,
    Youjun Tang


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, February 23, 2015 7:52 AM
  • Hi,

    check this: http://www.lasrapp.com/forum/index.php?topic=321.0

    The similar issue as yours.

    Monday, February 23, 2015 7:58 AM
  • Hi Youjun,

    Thank you for your answer but why does ReportViewer.msi deployment can't be automatic in Vista ?

    I managed to do it this week with a batch file in a .sfx package.

    Best regards,

    Monday, February 23, 2015 8:10 AM