Sharepoint Search finding no results for some users


  • Alright I've been at this one for days now so I'm pleading that someone can help me out. The crawler is working just fine, indexing over 30,000 items. I can search just fine with my account. My account is a domain admin, site collection owner, and full site owner. Domain users who are site members receive a "No results matching your search were found."

    I'm completely lost- I one of my end users a domain admin, secondary site collection admin, and site owner and they still cannot query results. I made sure they have access to everything on the site including all permissions for the search center. I've tried reseting the index and using the end users own account to recrawl/reindex which succeeded. However still no results found when doing a search. I've tried changing the search service log on accounts to other domain accounts as well to no avail. Anyone have any ideas or troubleshooting steps that would guarantee search is setup correctly? Like I said, my user account is able to perform searches and recieve results but I cannot figure out what permission my account has over the other end user account I assigned permissions to.

    Another thing to note is that this was a standalone MOSS 2007 upgrade to 2010. All prerequisits were installed and the upgrade went smoothly.

    Please help!

    Tuesday, October 26, 2010 7:42 PM


All replies

  • Take a look at this search related config info:

    You definitely need a domain account for the search service, and you also want to set the Default Content Access Account.  The Default Access Account should also be given read access to the content databases.

    SharePoint Server MVP | Architect | Developer | Administrator | Speaker-- Twitter -- Blog -
    • Marked as answer by Eric_Feyrer Tuesday, October 26, 2010 8:38 PM
    • Unmarked as answer by Eric_Feyrer Tuesday, October 26, 2010 8:48 PM
    Tuesday, October 26, 2010 8:23 PM
  • I went through that list a few times to verify that I had everything set. Still not working for all users. My dummy account that I set as domain admin, site collection admin, and site owner started getting results so I thought that adding NT Authority\authenticated users to the visitors group permissions of the search center had done the trick, but apparently not.

    The search service is running under a domain administrator account, as well as the default content access account (althought I know they recommend using a normal user, however I've tried it both ways reindexing each time to no avail). Any other suggestions?


    *edit* Just wanted to add that the search feature was working before the upgrade to 2010. As well I can search and get results from my own account, just not other users.

    Tuesday, October 26, 2010 8:59 PM
  • Another interesting thing I just realized. It seems that when I set up new users (no special permissions, just domain users, site members) they can all search fine. It's only existing users from before the upgrade that cannot search.
    Friday, October 29, 2010 2:57 PM


    That blog resolved my problem. I just added the sharepoint search service to the windows authorization access group and everyone was able to search.

    • Marked as answer by Eric_Feyrer Friday, October 29, 2010 4:05 PM
    Friday, October 29, 2010 4:04 PM