none
Can't refer "Presentation.Framework version =4.0.00" in a WPF library project which target .NETCore 3.0 RRS feed

  • Question

  • We are working on a WPF library, which uses a Presentation.Framework as dependent. When we use this WPF library with .NETFramework 4.6.1 target, it works properly in our end. But we are facing a error “Could not load file or assembly 'PresentationFramework, Version=4.0.0.0” while using this WPF library with .NET Core 3.0 target.


    Please help me to resolve this issue in our end.

    Note: We cannot install the PresentationFramework Version=4.0 package manually in NET Core 3.0 targeted WPF library.
    Thursday, April 2, 2020 6:07 PM

All replies

  • Have you reviewed the Core compatibly documentation?

    https://docs.microsoft.com/en-us/dotnet/core/porting/third-party-deps

    However, some libraries that are not Core or .NET Standard will remain incompatible with.NET Core.

    Thursday, April 2, 2020 7:57 PM
  • Hi Ebenezer94,

    Thank you for posting here.

    PresentationFramework seems to be specific dll for .NET framework, it does not apply to .NET Core.

    You can ask questions about WPF under the WPF tag of Microsoft Q&A and tell them the features you want to implement, maybe they can tell you how to implement these features in .NET Core.

    Best Regards,

    Timon


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, April 3, 2020 7:08 AM