none
Problems with JSON Response String from WCF RRS feed

  • Question

  • Hello, I've a quick question.  I converted a WCF service from XML to JSON on the fly.  My JSON response always returns numeric characters around the response, when I test it in fiddler.  My third party tool tells me "invalid JSON" when I try to parse it.  What is wrong here?

    185f
    [{CORRECT JSON HERE}]
    0

    Wednesday, April 22, 2015 10:00 PM

Answers

  • Amy,

    thanks for the reply.  I solved the issue; it was actually a parameter in the web.config.  Anybody else looking for this: change "transferMode" on the binding from "Streamed" to "Buffered".

    • Marked as answer by jdb1a1B Thursday, April 23, 2015 12:32 PM
    Thursday, April 23, 2015 12:32 PM

All replies

  • Hi jdb1a1B,

    For this issue, please try to post a simple reproduced project in here.

    Best Regards,
    Amy Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.



    Thursday, April 23, 2015 9:16 AM
    Moderator
  • Amy,

    thanks for the reply.  I solved the issue; it was actually a parameter in the web.config.  Anybody else looking for this: change "transferMode" on the binding from "Streamed" to "Buffered".

    • Marked as answer by jdb1a1B Thursday, April 23, 2015 12:32 PM
    Thursday, April 23, 2015 12:32 PM