Error 2738 running tfpt.msi v1.2


  • 1.Uninstalled the old Process Template Editor.

    2.Installed the DSL Tools.

    3.Installation of Power Tools 1.2 gives "Internal Error 2738" and finishes saying 'wizard interrupted', 'run setup later'.

    Can anyone provide details of that error?

    Thursday, February 22, 2007 8:47 PM


  • Running the tfpt.msi via command line and creating a log says "Internal Error 2738" is a vbscript runtime error. Typing "regsvr32 vbscript.dll" fixed the problem. Running the Power Tools install again was then successfull.
    Wednesday, February 28, 2007 5:30 PM

All replies

  • I have had a problem installing to. I followed the same steps but when running tfpt.msi from my hard drive I get the error:

    Error 1316: A network error occurred while attempting to read from the file D:\tfpt[1].msi

    If I download the msi and immediatley run it (i.e. don't save first) the install goes ahead OK. The only problem is I can't see the process editor anywhere.


    Friday, February 23, 2007 10:08 AM
  • My missing process editor and the network issue were fixed by installing the DSL tools. See http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1262089&SiteID=1
    Friday, February 23, 2007 10:43 AM
  • Running the tfpt.msi via command line and creating a log says "Internal Error 2738" is a vbscript runtime error. Typing "regsvr32 vbscript.dll" fixed the problem. Running the Power Tools install again was then successfull.
    Wednesday, February 28, 2007 5:30 PM
  • Same error code (2738) on MSI install/uninstall of Cloudmark SpamNet under Vista.


    Running CMD as Administrator:

    cd %windir%\System32

    regsvr32 vbscript.dll


    Worked great. Thanks! Smile


    • Proposed as answer by cdfdfireman Tuesday, November 11, 2008 9:00 PM
    Tuesday, March 27, 2007 5:23 PM
  • tnx...  I had  great help with this. tnx...
    Friday, May 18, 2007 8:02 AM
    Tuesday, May 22, 2007 2:40 AM
  • Run windows script 5.6
    Thursday, May 24, 2007 7:31 PM
  • i have tried both fixes mentioned for error code 2738. microsoft is no help at all. anyone else have a solution. maybe dropping vista and restoring xp is the answer.
    Thursday, June 28, 2007 2:07 PM
  • That worked perfectly, thanks! (Was getting this error trying to run Dell Mobile Broadband Utility driver installer.)
    Thursday, July 12, 2007 10:29 AM
  • I had the same error trying to install itunes, here is my fix.(for Vista 64 bit)

    I had the 2738 error for both Quicktime and Itunes. The solution of running the command; regsvr32 vbscript.dll in the system32 folder did not work for me.
    I'm running Vista 64 Bit Home Edition. After much trail and error this is what worked.
    open Command Prompt using a right click "Run as Administrator".
    cd to C:\windows\syswow64
    type- regsvr32 vbscript.dll, then hit enter.
    This is not an official solution but it worked for my 64 bit system.
    Sunday, October 21, 2007 12:44 AM

    Thank you Richny44!!  your solution worked for me.
    Sunday, November 04, 2007 6:56 PM
  • Try going to www.blackberryforums.com 

    BlackBerry Desktop Manager installation internal error 2738

    Doc ID : KB03490
    Last Modified : 2007-06-06
    Document Type : Support

    • BlackBerry® Desktop Software 4.0 and later
    • Microsoft® Windows® 2000
    • Microsoft Windows XP
    • Microsoft Windows Vista™

    The following error message is received while installing, modifying, or uninstalling BlackBerry® Desktop Manager:

    Internal Error 2738. Could not access VBscript.


    BlackBerry Desktop Manager requires that Microsoft Visual Basic® Script be registered on Microsoft Windows Vista.


    Complete the appropriate resolution for your environment.

    Microsoft Windows 2000/XP

    On the Microsoft web site, download the Microsoft Windows Script 5.6 install for your operating system.

    Microsoft Windows Vista

    Unregistration and re-register the vbscript.dll file. To do so, complete the following steps:
    1. Select Start > Accessories > right-click Command Prompt and select Run as administrator.
    2. The Command Administrator Prompt opens to C:\Windows\system32>
    3. Unregister the vbscript.dll first and then re-register it C:\Windows\system32> regsvr32 /u vbscript.dll (This unregisters VB Script with your computer.)
      C:\Windows\system32> regsvr32 vbscript.dll (This register VB Script with your computer.)
    4. A pop-up window will appear, indicating the DLL file was registered successfully.
    5. Run the BlackBerry Desktop Manager installation again.
    Note: If it fails to register, search for the vbscript.dll file on your computer. Copy and paste the file to the C:\Windows\System32 folder.
    Friday, February 08, 2008 5:25 PM
  • Thank you Richny44,


    And thank you Delorme technical support for pointing me here.  I have Delorme Topo USA version 6.0 and was having trouble running the utility to copy the topo DVD to my hard drive.  After reporting the 2738 error to Delorme TS they suggested I try the steps here.


    I too have Windows 64 bit Vista and the solution of running the command regsvr32 from the system32 folder didn't work for me either, but running it from the syswow64 folder did.




    And to top that off, I also have a Blackberry 8820 and was planning on installing the BB desktop software on this new computer this weekend, so it looks like I may have killed two birds with one stone :-)


    Thanks again,




    Thursday, February 14, 2008 4:42 AM

    Thursday, February 21, 2008 4:05 AM
  • thx for ur info, i have problem installing quick time and i tried that application, its worked. thx once again


    Saturday, May 10, 2008 11:10 AM
  • Thanks Richny44, I have Vista Ultimate x64 as well, and this fixed the Error 2738 for my Blackberry Desktop setup!  Woohoo!
    Sunday, May 18, 2008 8:22 AM
  • This worked for me, after many other failed attempts.  Thank you so much for posting.  :-)
    Thursday, July 03, 2008 1:26 AM
  • Outstanding... trying to install for two days... thanks


    Tuesday, October 07, 2008 3:31 PM
  • This also worked for me when the Backup Exec Desktop and Laptop Option (version 12) wouldn't install on my Windows Vista machine.
    Thursday, October 23, 2008 3:48 PM
  • RichNY44's solution worked for me on my Vista Home Premium 64 bit.
    Saturday, August 28, 2010 10:25 PM