locked
The underlying connection was closed RRS feed

  • Question

  • I wasn't able to find any way of resolving this with a quick search on the forum.

    I'm using "Microsoft Team Foundation Server MSSCCI Provider" with MSVS.NET 2003.

    Having created a new project, I'm attempting to check in an existing project (that was originally under Source Control with Visual Source Safe) to the TFS.

    I receive the following error upon clicking the "Check In" option of the SCC Provider.

    "The underlying connection was closed: A connection that was expected to be kept alive was closed by the server."

     

    Any ideas?

    Wednesday, July 5, 2006 9:06 AM

Answers

All replies

  • Use the SCP Selector to switch between source control providers.

    http://weblog.kilic.net/tools/SCPSelector/

    Wednesday, July 5, 2006 12:28 PM
  • Thanks for the response.
    Looks like a nice utility and will be very useful.

    However I still experience the same problem.

    I also experience the problem (having now tried) when checking in a project that is not under a previous SCP.

    I am also having a problem with the 2005 TFC disconnecting (Application tier connection was lost).

    The network is set up as follows:

    We have an internal server dedicated to TFS (Workgroup Edition) running Windows Server 2003 SE SP1. The database for TFS resides on this machine also.

    External access is managed by ISA Server 2004 SP2 through one dedicated server, this is also running on Windows Server 2003 SE SP1. Having spoken to my network administrator it is my understanding that internal traffic should not route through ISA (although I can't say that for sure).

    Finally, we have a domain control server running Windows Small Business Server 2003 SP1. Other than for network authentication this server is not related to TFS.

    Wednesday, July 5, 2006 1:36 PM
  • Can you see if other TFS clients can connect to the VSTF server? In other words, is this issue isolated to your client or is it a server side or network issue?
    Wednesday, July 5, 2006 6:13 PM
  • Thanks for your suggestion.
    I've been able to fix the problem.

    Having tried it on another machine it worked fine, the cause of the problem on my machine (and
    several others) was Norton Internet Security 2006 with Norton AV.


    Even with a dedicated rule it does not work. Hopefully this information will be useful in future.
    I have no removed Norton as we are currently migrating to a new AV provider
    Thursday, July 6, 2006 3:08 PM
  • Thanks for your investigation. This is unfortunately not the first
    strange error we’ve seen with a root cause in NAV.
    Thursday, July 6, 2006 4:31 PM
    Moderator