none
hi RRS feed

  • Question

  • hi  guys

    am really fed up with the issue.

    Am using asp.net 2008 and mssql2005 to develop my web application.it was working fine my system.once i try to access using IIS it showing like

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
    and i given <customerrors mode="Off">
    but still am getting the same .
    Can anybody help me?
    </configuration>

    Sunday, January 23, 2011 10:41 AM

All replies

  • Ignore the redirect to a custom page.  You don't want that.  You want to see the actual errors.  Follow the first instruction.  And if it still says you have to do it: you haven't.  Make sure you are working with the web.config in the root of your Application, and that the web.config has no errors.
    Sunday, January 23, 2011 2:43 PM
  • ???

    I'm not sure what your post being interspersed with the error message means, but until you properly configure your web.config file to turn off custom error messages (as described in the first part of the message above) and then post the contents of the actual error message, no one is going to be able to help you.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    Sunday, January 23, 2011 2:47 PM
  • Have you set your site as the application root in IIS?
    Right click My Computer.
    Click Manage.
    Click the plus by Services and applications.
    Click the plus by Internet information Services, then web sites, then default web site.
    Right click the folder for your site and select Properties.
    In the Apllication settings section of the dialog click the Create button.
    The folder name for your site should now appear in the application name textbox.
    Click Apply.
    You may have to restart IIS, by right clicking Internet Information Services and selecting Restart.
    Close computer management.

    Now try your asp page.


    Expression Web MVP

    Sunday, January 23, 2011 3:38 PM