locked
Troubleshooting connections from Internet Explorer & Visual Studio to Visual Studio Online

    General discussion

  • Has your connectivity to Visual Studio Online (VSO) from Visual Studio suddenly stopped working or it's giving you trouble? Are you able to log in via the web, just not from VS? If so, this may be due to a bad cookie or cache. We rely on cookies \ IE for our VS connectivity settings, so you may be able to clear this up by following the steps below.

    The goal here is to get this sign in dialog to appear when you initiate a connection from VS to Visual Studio Online (pictured below). Unless your credentials are stored correctly (cookie) you will not be able to connect to Visual Studio Onlinefrom VS unless you see & use this dialog.


    NOTE: The steps below apply to all versions of VS, but for VS 2008 & 2010 you also need to do ensure all the necessary updates are installed*. When in doubt, use Control Panel>Programs & Features to remove the updates and reinstall them if the steps below do not restore your VS 2008\2010 connectivity.

    *To connect to VSO VS 2008 you need VS 2008 SP1 and this GDR.

    *To connect to VSO from VS 2010 you need VS 2010 SP1 and this GDR.


    Delete the Visual Studio Online  cookies
     

    1. Close all browser instances, Skype, Skype, etc... anything else that is signed in with your Microsoft account (formerly "Live ID").

    2. Open Internet Explorer (don’t use InPrivate) and navigate to https://app.vssps.visualstudio.com/_signout. This will delete live cookies, feadauth tokens for all VSO accounts and also sign you out Azure Active Directory.

    3. Use Internet Explorer to delete all your Temporary Internet File and Cookies. In later versions of IE you can access this dialog by pressing CTRL+SHIFT+DEL. Otherwise it's under Internet Options>General>Browsing History>Delete. Be sure to delete cookies and uncheck the "Preserve Favorites website data" item

     

    I’d also suggest manually deleting the contents of these folders using File Explorer (DIR path may be different depending on your OS):

    • C:\Users\[YOUR NAME]\AppData\Local\Microsoft\Windows\Temporary Internet Files
    • C:\Users\[YOUR NAME]\AppData\Roaming\Microsoft\Windows\Cookies
    • C:\Users\[YOUR NAME]\AppData\Local\Microsoft\Windows\INetCookies

    Rename the TFS \ VS Cache

    1. Close all open instances of Visual Studio (**IMPORTANT**).

    2. Run the following from a .CMD in an elevated Command Prompt.

     

    SET AppDataTF=%USERPROFILE%\Local Settings\Application Data\Microsoft\Team Foundation

    SET AppDataVS=%APPDATA%\Microsoft\VisualStudio

     

    IF EXIST "%AppDataTF%\2.0\Cache" MOVE "%AppDataTF%\2.0\Cache" "%AppDataTF%\2.0\Cache.OLD"

    IF EXIST "%AppDataTF%\3.0\Cache" MOVE "%AppDataTF%\3.0\Cache" "%AppDataTF%\3.0\Cache.OLD"

    IF EXIST "%AppDataTF%\4.0\Cache" MOVE "%AppDataTF%\4.0\Cache" "%AppDataTF%\4.0\Cache.OLD"

    IF EXIST "%AppDataTF%\5.0\Cache" MOVE "%AppDataTF%\5.0\Cache" "%AppDataTF%\5.0\Cache.OLD"

     

    IF EXIST "%AppDataVS%\9.0\Team Explorer" MOVE "%AppDataVS%\9.0\Team Explorer" "%AppDataVS%\9.0\Team Explorer.OLD"

    IF EXIST "%AppDataVS%\10.0\Team Explorer" MOVE "%AppDataVS%\10.0\Team Explorer" "%AppDataVS%\10.0\Team Explorer.OLD"

    IF EXIST "%AppDataVS%\11.0\Team Explorer" MOVE "%AppDataVS%\11.0\Team Explorer" "%AppDataVS%\11.0\Team Explorer.OLD"
    IF EXIST "%AppDataVS%\12.0\Team Explorer" MOVE "%AppDataVS%\12.0\Team Explorer" "%AppDataVS%\12.0\Team Explorer.OLD"

    If after doing all this you are still having issues, try:

    1. Resetting Internet Explorer settings to default by opening Internet Options, going to the Advanced tab and clicking the "Reset..." button at the bottom of the dialog.

    2. Removing and re-adding the VSO account inside VS using the "Connect to Team Foundation Server" dialog

    3. Check the Credential Manager (accessible via Control Panel) for stored Windows creds. You may need to clear these out too as they could override your cookies.

    4. Check your proxy settings inside IE. If you can access the Internet without a proxy, disable the proxy as a test. We have seen proxy settings here which prevent the Microsoft account login dialog (pictured at the top of this post) from appearing.

     


    Trevor Hancock (Microsoft)
    Please remember to "Mark As Answer" the replies that help.








    Tuesday, March 05, 2013 4:12 PM
    Owner