locked
maxRequestLength Error RRS feed

  • Question

  • User-487061326 posted

    I’ve ran into a problem and can’t seem to find the appropriate solution.

    Background:

    We have created an archiving system for our buisness. The archiving system is fully searchable and will include files for each entry. The files will be stored in SQL.

    Problem:

    We have ran into a maxRequestLength error when uploading files over 4 megs in size (Link). We have found that the appropriate solution should be changing the max file size in Machine.config file. The problem is that the <httpruntime> section does not exist in our windows/Microsoft.NET/Framework/v2.0.50727/config. I’m looking for a little help on solving this problem. From my experience I’m guessing we are just going to have to copy and paste that section in from a machine.config.comments file or a machine.config.default file. I’m not an admin/programmer by trade and only have limited access to system. If someone has some insight on where to get this info that would be great. 
    </httpruntime>

    Saturday, June 2, 2007 12:35 PM

Answers

  • User-225114762 posted

    It will solve your problem (if your problem is the maxRequestLength). You can add things to Web.Config. ASP.NET merges the various config-files, including Machine.Config etc with your local Web.Config and the defaults to get the valid options for the given location. See http://msdn.microsoft.com/en-us/library/e1f13641.aspx for details about the element in question.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, June 3, 2007 2:42 PM

All replies

  • User-319574463 posted

     Have a look at

    • http://msdn.microsoft.com/en-us/library/system.web.configuration.httpruntimesection.maxrequestlength.aspx - this implies that the limit can be increased programatically without changing web.config
    • http://www.motobit.com/help/scptutl/pa84.htm - this gives the systam to insert into your web.config
    Saturday, June 2, 2007 1:19 PM
  • User-225114762 posted

    You should (re-)configure this limit in your applications Web.Config, not in the Machine.Config. Just add the element to the Web.Config in your applications root directory and all will be well.

    Sunday, June 3, 2007 12:24 PM
  • User-487061326 posted

    Thanks for the suggestions.  I'll double check the webconfig but I don't think it is going to solve the problem as I don't think it is even referenced in the config...I'll have to double check to be sure. 

     
     

    Sunday, June 3, 2007 2:10 PM
  • User-225114762 posted

    It will solve your problem (if your problem is the maxRequestLength). You can add things to Web.Config. ASP.NET merges the various config-files, including Machine.Config etc with your local Web.Config and the defaults to get the valid options for the given location. See http://msdn.microsoft.com/en-us/library/e1f13641.aspx for details about the element in question.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, June 3, 2007 2:42 PM