locked
Intermittent HTTP 500.19 error RRS feed

  • Question

  • User-86807006 posted

    Hi,

    We are currently running a Windows web server with approximately 250 sites and are recieving an intermittent 500.19 error, which affects a random selection of sites, and it affects ASP, ASP.NET and sites with naked HTML.

    We see the following error when we view an effected site (apologies for munging):

     Server Error ============ Internet Information Services 7.0 Error Summary HTTP Error 500.19 - Internal Server Error ----------------------------------------- The requested page cannot be accessed because the related configuration data for the page is invalid. Detailed Error Information Module IIS Web Core Notification BeginRequest Handler Not yet determined Error Code 0x80070038 Config Error Cannot read configuration file Config File \\?\UNC\10.0.3.25\home\domain.co.uk\public_html\web.config Requested URL http://domain.co.uk:80/ Physical Path \\10.0.3.25\home\domain.co.uk\public_html Logon Method Not yet determined Logon User Not yet determined Config Source -1: 0: Links and More Information This error occurs when there is a problem reading the configuration file for the Web server or Web application. In some cases, the event logs may contain more information about what caused this error. [1]View more information » 1. http://go.microsoft.com/fwlink/?LinkID=62293&IIS70Error=500,19,0x80070038,6001

    This is often accompanied in the event log with an event with the message : 

    Could not load all ISAPI filters for site 'DOMAIN.CO.UK'.  Therefore site startup aborted

    I've previously seen a similar error reported at the link below, but this does not seem to help us as changing the MaxCmds registry entry seemingly has no effect.
    http://forums.iis.net/t/1157405.aspx

     The web server is Windows Server 2008 and the UNC share is a RHEL box with samba, site authentication is set to a specific domain user, asp impersonation is enabled, and all sites have individual application pools with their identity configured to the specific domain user.

    When we run Network Monitor, we seem to find packets indicating that Windows has failed to send packets it's requested a response from for an affected site, however the network is running at 30-50% of available bandwidth and very occasional TCP sacks seem to be unrelated to this problem.

     I would appreciate if any one could point me in the right direction.

    Friday, June 26, 2009 12:26 PM

Answers

  • User511787461 posted

    http://technet.microsoft.com/en-us/library/dd296694(WS.10).aspx talks about how to tune the various smb parameters to match your load - of course the unc server side of the instructions will not apply since you are not using a windows server for that, but you would probably need to find similar instructions for samba.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, June 26, 2009 12:45 PM
  • User-86807006 posted

    Thanks Anil for your help, however I am still confused on a couple of points:

    a) Is the  HKLM\System\CurrentControlSet\Services\LanmanWorkstation\Parameters\ MaxCmds registry key valid for Windows server 2008? Does it require a reboot of the computer?

    b) samba default configuration is by default very high and set to the maximum allowable limits by the OS. The broken SMB packets seem to be originating from the web server. Is it possible that we are hitting the maximum limit for supported web sites?

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Saturday, June 27, 2009 6:31 AM
  • User1073881637 posted

    Yes - It's applicable to IIS 7.

    http://technet.microsoft.com/en-us/library/dd296694(WS.10).aspx

    Dealing with a non-Windows OS as a UNC content is almost always more interesting than a windows backend when it comes to tuning.   This article is a good starter.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Saturday, June 27, 2009 10:20 PM
  • User-86807006 posted

    Many thanks to both Anil and Steve. The root cause for the prevailing intermittent HTTP 500 error did appear to be that the MaxCmds registry setting is by default too low. To alleviate the issue, I created the MaxCmds dword, gave it a higher value, rebooted the web server and set the max mux configuration setting in samba to the same setting.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, July 2, 2009 7:04 AM

All replies

  • User511787461 posted

    http://technet.microsoft.com/en-us/library/dd296694(WS.10).aspx talks about how to tune the various smb parameters to match your load - of course the unc server side of the instructions will not apply since you are not using a windows server for that, but you would probably need to find similar instructions for samba.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, June 26, 2009 12:45 PM
  • User-86807006 posted

    Thanks Anil for your help, however I am still confused on a couple of points:

    a) Is the  HKLM\System\CurrentControlSet\Services\LanmanWorkstation\Parameters\ MaxCmds registry key valid for Windows server 2008? Does it require a reboot of the computer?

    b) samba default configuration is by default very high and set to the maximum allowable limits by the OS. The broken SMB packets seem to be originating from the web server. Is it possible that we are hitting the maximum limit for supported web sites?

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Saturday, June 27, 2009 6:31 AM
  • User1073881637 posted

    Yes - It's applicable to IIS 7.

    http://technet.microsoft.com/en-us/library/dd296694(WS.10).aspx

    Dealing with a non-Windows OS as a UNC content is almost always more interesting than a windows backend when it comes to tuning.   This article is a good starter.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Saturday, June 27, 2009 10:20 PM
  • User-86807006 posted

    Many thanks to both Anil and Steve. The root cause for the prevailing intermittent HTTP 500 error did appear to be that the MaxCmds registry setting is by default too low. To alleviate the issue, I created the MaxCmds dword, gave it a higher value, rebooted the web server and set the max mux configuration setting in samba to the same setting.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, July 2, 2009 7:04 AM
  • User1073881637 posted

    Thanks for posting the solution and / or workaround.  I'll add this to my tag of UNC connections.

    http://weblogs.asp.net/steveschofield/archive/tags/UNC/default.aspx

    Thursday, July 2, 2009 7:15 PM
  • User1446735698 posted
    Steve, Do you know if MaxCmds is applicable even if the Web Server and the File Server are both Windows 2008 Server? If so, is there registry settings that need to be changed on both servers, or does MaxCmds just get set on the Web Server? Our File Server was running Windows 2003 where we had made the registry hack and then this morning we upgraded to Windows 2008 Server and now we are having performance problems over the UNC connection. We did not make any registry changes on the new 2008 Server because we thought it was no longer necessary. Any ideas? Thanks, Kelsey
    Thursday, September 30, 2010 6:18 PM