locked
IAP : This in-app purchase item is no longer available RRS feed

  • Question

  • I create a new IAP in store with the Product ID "Donate". Then I make request to this IAP in the app, here is the code:
    var purchaseResults = await CurrentApp.RequestProductPurchaseAsync("Donate");
    

    However, when I call the function in my windows app, an error message dialog is shown:

    Choose another item : This in-app purchase item is no longer available in My App Name

    and I tried call var listingInfo = await CurrentApp.LoadListingInformationAsync();var productListings = listingInfo.ProductListings;It seems that there is no product in the list.

    Then I tried to submit an "empty updates" to my IAP, however after the update the problem remain.

    How would this happened? Thanks!


    • Edited by Yang Shue Monday, February 8, 2016 12:55 PM
    Monday, February 8, 2016 12:54 PM

Answers

  • Hello Yang Shue,

    Have you checked the dashboard to see if your “Donate” exist there?

    And could you please refer to here https://msdn.microsoft.com/en-us/library/windows/apps/mt219692.aspx to call the receipt and see if your product exist there?

    I think it is possible that your item has not been successfully added to the dashboard. If that is the problem, maybe recreate the item or ask here https://dev.windows.com/en-us/support to search for some assistant.

    In our forum we can only help you check your code, and it seems your code do not have problem here.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Barry Wang Thursday, February 25, 2016 3:18 AM
    • Marked as answer by Barry Wang Thursday, February 25, 2016 7:58 AM
    Tuesday, February 9, 2016 5:08 AM