none
OST won't download, can't access mailbox in cached mode RRS feed

  • Question

  • I'm developing for a particular Exchange deployment I have no admin rights or access to and I can't seem to connect Outlook to it in cached mode.  I'm able to connect just fine through autodiscover in online mode, but for some reason my cached .OST mailbox does not properly download as part of the initial autodiscover process.  I can see the .OST file in my AppData folder but it usually only makes it to about 16MB when in reality my mailbox is several GBs.  I'm currently using Outlook 2016 but have had the same exact problem with Outlook 2013.  We use smart cards and ActivClient software, FWIW.

    Is there any type of logging Outlook does to help diagnose this issue?  Any etl logs or parsers available?  I took a look at it for several hours using process monitor but was unable to find the culprit.


    Thursday, November 15, 2018 9:50 PM

Answers

  • Using MFCMAPI I was able to obtain the exact error message I was getting as:

    MAPI_E_LOGON_FAILED == 0x80040111



    Some searching on the web revealed that I needed to go to the following key in the registry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\Protect\Providers\df9d8cd0-1501-11d1-8c7a-00c04fc297eb



    and then add a registry value called ProtectionPolicy (dword) and set it to 1, ie 00000001



    After doing this, I was able to connect Outlook 2016 to Exchange 2010 in cached mode.
    Wednesday, February 6, 2019 6:07 PM