locked
ASP form quits working on upload RRS feed

  • Question

  • My web page contact form (ASP file) was created in Dreamweaver by my web host. I use WE to make edits. Lately, when I edit text in the form (not the form fields, just the text) and then upload to my web site (I use Filezilla FTP to upload), the form sends back an error page. When my web host contact goes to take a look at the form, he reports that the code is "all jumbled up." Also, my includes files, when edited and uploaded, appear with nonsense characters like +?/^7 at the very top of the page, which looks weird and messes with the spacing. Has anyone ever heard of this and how to fix it? I have to pay my web host company every time they have to remove the jumble and nonsense characters from these files.
    Thursday, March 13, 2008 6:48 PM

Answers

  • Hi Kim,

    There may be several issues at play here, but let me start with the most obvious. Expression Web I automatically inserts 3 invisible characters at the top of each page it creates. These are called a "Byte Order Mark" (or "BOM"). This is a recommendation of the W3C, but not every system is compati9ble with it. EW II has an option to disable BOM marks in pages, but EW I does not. It is difficult to remove them, since EW and NotePad do not show them. There are some recommendations about how to disable them and remove them from existing pages on the following web sites:

    http://by-expression.com/tutorials/characterset/index.aspx
    http://www.95isalive.com/expression/index.html

    Here is the location of a Macro you can add to Expression if you know how to use Macros:
    http://groups.google.com/group/microsoft.public.expression.webdesigner/msg/b3d5c9a3e477f729?dmode=source

    Now, this may take care of all of your issues, but it may also be possible that your editing is changing some ASP code in your pages as well. You should be aware that ASP pages contain both HTML and programming code, often interspersed together. When editing the HTML, make sure you don't remove, change, or rearrange any ASP code in them.

    HTH

    Kevin Spencer, Chicken Salad Alchemist
    Friday, March 14, 2008 1:33 PM

All replies

  • Hi Kim,

    There may be several issues at play here, but let me start with the most obvious. Expression Web I automatically inserts 3 invisible characters at the top of each page it creates. These are called a "Byte Order Mark" (or "BOM"). This is a recommendation of the W3C, but not every system is compati9ble with it. EW II has an option to disable BOM marks in pages, but EW I does not. It is difficult to remove them, since EW and NotePad do not show them. There are some recommendations about how to disable them and remove them from existing pages on the following web sites:

    http://by-expression.com/tutorials/characterset/index.aspx
    http://www.95isalive.com/expression/index.html

    Here is the location of a Macro you can add to Expression if you know how to use Macros:
    http://groups.google.com/group/microsoft.public.expression.webdesigner/msg/b3d5c9a3e477f729?dmode=source

    Now, this may take care of all of your issues, but it may also be possible that your editing is changing some ASP code in your pages as well. You should be aware that ASP pages contain both HTML and programming code, often interspersed together. When editing the HTML, make sure you don't remove, change, or rearrange any ASP code in them.

    HTH

    Kevin Spencer, Chicken Salad Alchemist
    Friday, March 14, 2008 1:33 PM
  • Thanks for the tip Kevin. I appreciate hearing that I am not the only one who has experienced this. It's good to know there may be a fix.

    Kim
    Thursday, March 20, 2008 12:42 PM