none
"The type initializer for 'LitDev.LDSpeech' threw an exception" Error Message on Windows 7 RRS feed

  • General discussion

  • Hello,

    I wrote a program in Small Basic to help (Thai) students practice French listening and speaking.

    I'm using some LitDev functions, especially LDSpeech.

    My laptop runs Windows 10 (64 bit).

    My problem is that, when I try to run my program in the computer room, which computers have (fully up-to-date) Windows 7 Ultimate (32 bit), I get the following error message :

       "The type initializer for 'LitDev.LDSpeech' threw an exception.
       at LitDev.LDSpeech.Voices()
       at _SmallBasicProgram._Main()".



    Would anyone know anything that could help solve that problem?

    Thank you very much for any hints and comments. :-)

    --J.

    PS: There are two voices installed on the computer:




    Monday, July 3, 2017 11:53 AM

All replies

  • Does the simple test sample I provided before work?

    voices = LDSpeech.Voices()
    For i = 1 To Array.GetItemCount(voices)
      TextWindow.WriteLine(voices[i])
      LDSpeech.Voice = voices[i]
      LDSpeech.Speak("Hello World")
    EndFor

    If it doesn't work then I don't really know what the issue may be.

    If this sample does work, then please provide a short code segment that fails for you that can be run by us.

    Monday, July 3, 2017 12:52 PM
    Moderator
  • I get the same error message

    by just running this one-line program:

    voices = LDSpeech.Voices()

    I also got this message on Windows 10 after installing the French voice Hortense. It turned out that a simple reboot solved the problem.

    So I will try this solution on Windows 7 tomorrow...

    --J.


    Monday, July 3, 2017 5:09 PM
  • Rebooting the computer does not solve the problem on a Windows 7 Ultimate 32 bit.

    I tried on two different computers having Windows 7 Ultimate 32 bit and I always get the same error message...

    ...when running this one-line program:

    voices = LDSpeech.Voices()

    Then, I tried on a Windows 7 Starter 32 bit (and also 64 bit) and it worked.

    So the problem might come from Windows 7 Ultimate.

    --J.

    Tuesday, July 4, 2017 6:22 AM
  • It seems I (accidentally) found the problem: LitDev stops working when, in "Region and Language", I change the language from "English (United States)" or "English (United Kingdom)" to "French (France)" or "Thai (Thailand)". (That was on a Windows 7 Starter. But maybe also on a Windows 10. Need to be confirmed.)

    --J.

    Sunday, December 2, 2018 10:39 AM