none
Windows 10 DirectShow problem with AVI RRS feed

  • Question

  • Hello,

    There is a problem with Windows 10 DirectShow: there sometimes can be an error 0x8004020d while playing the video in GraphEdit or GraphStudio. The file which is played is AVI and the problem must be in FileSource Async or AVI Splitter. In previous versions of Windows the file played without problems.

    Please let me know if you need more details or a sample file.

    Tuesday, August 11, 2015 12:30 PM

All replies

  • me too

    Stanislav Mikhailenko


    Monday, August 31, 2015 12:32 PM
  • see my reply

    Directshow, sound stops after 2 minutes when playing videofile (avi)

    got a workaround there.

    Thursday, September 3, 2015 9:32 AM
  • Taking into consideration the error code (0x8004020D VFW_E_BUFFER_OVERFLOW "The buffer is not big enough."), I would try (after connecting pins) to update memory allocator properties and increase pin connection buffer size - for the case it is this buffer size which is insufficient during streaming. It might so happen that comparison of connection between Widows 10 and earlier OSes immediately shows the difference.

    http://alax.info/blog/tag/directshow


    Wednesday, November 18, 2015 7:32 AM
  • I have the same problem with AVI files that contain DV video (have not tried any other formats). The files play to 2 mins 38.5 secs and aborts with 0x8004020D VFW_E_BUFFER_OVERFLOW.

    I tried with the video and audio pins both connected, the video pin only connected, and the audio pin only connected - in all 3 case the I got the same error.

    Thanks for the suggestion Roman - using GraphStudioNext I compared the allocator buffer sizes of the video and audio pins of the AVI Splitter but they seem to be the same in Windows 7 and Windows 10.

    I thought I would experiment with larger buffer sizes but I wasn't sure how to change the allocator properties after connection, so instead I modified the suggested buffer size of the video stream header (and the file header) in the AVI file to various larger sizes. GraphStudioNext shows that the allocated video buffer size is the same as the modified value. But this didn't help - same error.

    I also tried changing the suggested buffer size of the audio stream, but the allocator buffer size seemed to be unrelated to this value and was always the same.

    I also found this on the Solveig support forum which sounds like the same problem - after about 3 months they seem to have a workaround, but there's no clue what it is:

    http://www.solveigmm.com/forum/index.php?topic=4987.0

    Using the LAV Splitter can be a useful workaround in some cases, but not all software is able to use an alternative splitter, so this bug in the Microsoft AVI Splitter could potentially break some existing software. The AVI Splitter seems to have been stable for a long time, so goodness knows why Microsoft have messed about with it - we could really do with it being fixed.

    Edit> I also tried with the AVI Splitter connected to null renderer and that produces the error too, so it's definately the AVI SPlitter that is the problem.

    • Edited by roeville Wednesday, November 25, 2015 2:13 PM
    Sunday, November 22, 2015 1:06 PM
  • Finally I got Win 10 upgrade and I could easily reproduce the problem with DV AVI.

    The problem is apparently a bug in AVI splitter, in its CBaseMSRWorker class that fills output buffers with data. It stops at the same frame on every run for no apparent reason.


    http://alax.info/blog/tag/directshow

    Thursday, November 26, 2015 9:36 AM
  • Thanks for the info Roman, and for adding an article about it to your blog, here:

    http://alax.info/blog/1570

    Also I just installed the November update for Windows 10, and can confirm that the bug is still there.
    • Edited by roeville Tuesday, December 8, 2015 10:50 PM
    Tuesday, December 8, 2015 5:09 PM
  • Hello

    I have the same problem, windows 10 will choke on avi files using mjpeg codec that worked great in windows xp/7/8, and the problem is somewhere in the avi splitter since replacing that with another thrird party splitter like "LAV" or "Haali" fixes the error.

    This is critical since the program i have developed, which is a video subtitling software, no longer functions correctly in windows 10 unless a third party replacement of core directshow functionality, is installed.

    How do we report this bug to Microsoft so that they will actually take notice and start fixing it? It seems that the insider preview and feedback programs doesn't lead anywhere, the bug is already posted in several of these Microsoft forums without any reaction from them.

    cheers

    uffe

    Tuesday, February 2, 2016 9:50 PM
  • KB 3124262 should fix the issue.
    Monday, February 22, 2016 10:25 PM
  • Seems to be fixed with the Windows 10 "fall update" Version 1511, Build 10586.

    It contains Quartz.dll version 10.0.10586.71

    Regards,

    Stefan.

    Wednesday, March 2, 2016 1:39 PM
  • No, the fall update did not fix it. Mahatab seems to be correct.
    Wednesday, March 16, 2016 1:55 PM