locked
Running SSIS package once a month RRS feed

  • Question

  • I have around 10 packages, one of which needs to be run once a month.

    I don't have SQL server agent in my SSMS, was wondering if at all it is possible to schedule a package to run once a month(maybe with the help of procedures). As of now don't have any restrictions on what the date should be, so lets assume it has to run at the start of the month. Please help.

    • Edited by TNT2202 Sunday, June 28, 2020 3:22 PM
    Sunday, June 28, 2020 3:20 PM

All replies

  • You'll want to use SQL Server Agent to schedule package execution.

    You're probably not seeing SQL Server agent because you don't have certain permissions. SQL Server agent is always installed but in SQL Server 2019 it is disabled by default. 


    If my reply solves your issue, please mark it as the answer

    Sunday, June 28, 2020 8:27 PM
  • Hi TNT2202,

    Please use Task Scheduler to run the package, refer to:

    How to schedule a Batch File to run automatically in Windows 10.

    Best Regards,

    Lily


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, June 29, 2020 6:51 AM
  • you can run ssis package from another server with same sql connection.

    You can use Store procedure to call ssis packages.

    You can use powershell to run ssis packages.

    you can use Lily comment for schedule ssis packages.


    https://social.technet.microsoft.com/wiki/contents/articles/37872.sql-server-installation-on-centos-linux.aspx



    • Edited by AV111 Monday, June 29, 2020 8:07 AM
    • Proposed as answer by Lily Lii Tuesday, June 30, 2020 6:42 AM
    Monday, June 29, 2020 8:02 AM
  • I am not sure if I even have it, since I am using the 'Express Edition'.

    sp_configure 'show advanced options', 1;
    GO
    RECONFIGURE;
    GO
    sp_configure 'Agent XPs', 1;
    GO
    RECONFIGURE
    GO

    Tried the above, didn't help. Also I have admin access{Select IS_SRVROLEMEMBER('Sysadmin') --> '1'} 

    Monday, June 29, 2020 12:04 PM
  • I am not sure if I even have it, since I am using the 'Express Edition'.

    SQL Server-Agent is not supported in the free Express Edition as well as not SSIS to run automated packages, see Editions and supported features of SQL Server 2017

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Monday, June 29, 2020 12:11 PM
  • Hi TNT2202,

    Have you tried Task Scheduler? 

    1. create a new task:

    2. schedule the time:

    3. select the package you need to run:

    Program: "C:\Program Files (x86)\Microsoft SQL Server\110\DTS\Binn\DTExec.exe"

    Add arguments: dtexec /f "C:\yourpath\package.dtsx" /DECRYPT yourpassword

    Best Regards,

    Lily


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Proposed as answer by AV111 Wednesday, July 1, 2020 3:59 AM
    Tuesday, June 30, 2020 6:41 AM