locked
Message - No Web parts Found. How do i get them back? RRS feed

  • Question

  •  

    Hi

     

    I am new to Sharepoint 2007 and was progressing well under yesterday afternoon.  All of a sudden, when i tried to edit a page and add a web part, I was shocked to see that the web part area was empty, and the message No web parts found was showing up.  When I clicked on the advanced link, it indicates that there are no server web parts associated with this site.

     

    The functions work as expected on mySite.

     

    Help

     

     

     

    Thursday, March 6, 2008 3:35 PM

All replies

  • we are facing the same situation in our environment. the user has full control permission level but does get the message "no web parts found". if I go to the same WebPart page, I will see all web parts for the site (site collection administrator).

    I've verified the permission and it's still inherit from the parent. any support on that or should I create a Support Case for this?

    Thanks,

    Didier

    Monday, March 10, 2008 6:09 AM
  • Same probem for me.
    I have found the following reply to a similar problem:

    Assuming this is the same server environment, you can always go to the Web part gallery (Site Actions -> Site Settings [-> Modify all Site Settings], and then click on Web parts under Galleries.  Select any webpart you want to utilize in your Portal, and select Export.  In your portal, go to its Web part gallery, and select Upload to upload the existing web part you want to use.

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=1900233&SiteID=17

    For me, this solution is also not working, since I dont have access rights in the portal. Strangely enough, when I log in as a different user, the web parts are there!

    using MS Sharepoint Server 2007, i have "full control" rights (on the sharepoint, not on the portal)

    Any ideas?
    Friday, April 18, 2008 3:13 AM
  • I just found the following work-around for me:
    I logged in as a different user, who CAN add webparts. on any page, added a webpart and said "export". Then you can save the webpart to your harddisk. Then logged in with my own account > add webpart > Advanced Web part gallery and options > Import. There you can choose the web part you had just saved and there you go! Not a real solution, though. The webparts will still not appear in the list, but have to be imported every time.
    Friday, April 18, 2008 4:26 AM
  • We are having the ame issue with one of our site authors in only ONE of many site collections. Nothing in the ULS logs. Have tried everything. Starting to look less like a SharePoint error and more like a corrupt profile.

    Any resolutions?? Exporting web parts is not a solution. :)


    If at first you don't succeed, ask an MVP.

    Monday, February 20, 2012 12:36 AM
  • RESOLVED

    Dumb, dumb, dumb. Looks like one of our SC admins decided to break inheritance on the WP gallery because he didn’t want contributors making changes to them.

    Another mystery solved. :)


    If at first you don't succeed, ask an MVP.

    Monday, February 20, 2012 2:23 AM