none
WALinuxAgent issues when installing GUI Environment on CentOS RRS feed

  • Question

  • Hi,

    I'm attempting to install the Gnome desktop onto CentOS. I'm using the "Quick Create" option to create the VM I'm working in.

    Here are the steps I follow:

    1. Install X server with: yum groupinstall -y 'X Window System'
    2. Attempt to install Gnome with:  yum groupinstall -y 'Desktop'
    3. I receive the following WALinuxAgent error and can't find any help on it.

    --> Running transaction check
    ---> Package libatasmart.x86_64 0:0.17-4.el6_2 will be installed
    ---> Package mtools.x86_64 0:4.0.12-1.el6 will be installed
    ---> Package sg3_utils-libs.x86_64 0:1.28-4.el6 will be installed
    ---> Package smp_utils.x86_64 0:0.94-4.el6 will be installed
    --> Processing Conflict: WALinuxAgent-1.2-1.noarch conflicts NetworkManager
    --> Finished Dependency Resolution
    Error: WALinuxAgent conflicts with NetworkManager
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest

    I've attempted both "You could try" options to no avail. Once I get gnome installed I would like to setup XRDP on this box.

    Any help would be greatly appreciated. Thanks!



    • Edited by Wilshix Friday, January 25, 2013 11:43 PM Update the description
    Friday, January 25, 2013 11:43 PM

Answers

All replies

  • Dear Customer,

    According to this instruction, Please refer to the following article:

    http://blog.secaserver.com/2012/01/centos-enable-centos-gnome-desktop/

    Hope the above information helps.


    Friday, February 1, 2013 8:36 AM
    Moderator
  • Hi Tom,

    I believe I am following the instructions you've link to correctly. The problem appears to be with the WALinuxAgent.

    Thanks,
    Heath

    Monday, February 4, 2013 8:45 PM
  • Hi Wilshix,

    I believe you can install GNOME with the following steps. The problem happens since Windows Azure Linux Agent is not compatible with NetworkManager included in GNOME packages.

    I can install GNOME with these steps and please let me know if you meet any issues or problems.

    * Remove Windows Azure Linux Agent

    [root@machinename ~]# yum remove WALinuxAgent-1.3-1.noarch

    * Install X Window and GNOME

    [root@machinename ~]# yum groupinstall "X Window System" "Desktop" "Fonts" "General Purpose Desktop"

    * Install GUI tool like Free NX to access with GUI environment

    * Remove NetworkManager and install Windows Azure Linux Agent

     [root@machinename ~]# yum remove NetworkManager-0.8.1-34.el6_3.x86_64 

     [root@machinename ~]# yum install WALinuxAgent-1.3-1.noarch

    • Proposed as answer by Brad Kingsley Tuesday, April 30, 2013 11:05 AM
    Tuesday, February 12, 2013 2:07 AM
  • Heath,

    Please let us know if you are having this issue after the previous suggestion. I can ask our CentOS team who created the image respond if needed.

    Thanks!

    Patrick [MSFT]

    Tuesday, February 12, 2013 5:48 PM
    Moderator
  • I didn't post this question but I ran into the same issue and the workaround seems to have worked for me. The only difference is that the WALinuxAgent is version 1.3.2-1 now.
    Tuesday, April 23, 2013 8:01 PM
  • It works on my Azure RHEL 6.7 ! Great!

    My Windows Azure Linux Agent: WALinuxAgent-2.0.16-1.el6.noarch

    Monday, March 21, 2016 2:46 PM