locked
Problem with October 2008 Release of TFS Power Tools

    Question

  • Hi,
     
    I have recently installed the October 2008 release of the TFS Powertools and and am receiving the following error message when I start Visual Studio 2008 SP1:

    ---------------------------
    Microsoft Visual Studio
    ---------------------------
    Team Foundation Error

    Creating an instance of the COM component with CLSID {B69003B3-C55E-4B48-836C-BC5946FC3B28} from the IClassFactory failed due to the following error: 8007000e.
    ---------------------------
    OK  
    ---------------------------


    After some investigation I have found that if I disable the new "Team Members" function then this error does not appear.  Also if I shut down Windows Live Messenger prior to starting visual studio I do not receiver this error. However if I have Windows Live Messenger started ( either with an account signed in or not signed it ) I receive the error message if the "Team Members" feature is enabled.

    Any ideas what may be causing this problem?

    Thanks
    Daniel


    Daniel
    Sunday, November 09, 2008 11:18 AM

Answers

  • I had the same issue and found the solution:

    1. Open VS 2008 and wait until Team Members is not "working..."
    2. Right-click on it and select Personal Settings
    3. Under Collaboration, click Change
    4. On the opened dialog select None and click OK
    5. Click OK once again

    HTH.
    • Proposed as answer by sgwill Tuesday, December 23, 2008 2:21 PM
    • Marked as answer by Hua Chen Thursday, August 13, 2009 5:00 AM
    Monday, November 10, 2008 2:27 PM
  • I solved the problem after reading Brian Harry's latest post, right click on C:\Program Files (x86)\Windows Live\Messenger\msnmsgr.exe and select the Compatibility tab. Select 'Run this program as an Administrator". I've previously done the same thing to Visual Studio.

    Works fine now even though I don't like running Messenger as an administrator so maybe I'll just disable the whole Team Members stuff instead...


    Per
    • Proposed as answer by Bill.Wang Wednesday, November 12, 2008 4:38 AM
    • Marked as answer by Bill.Wang Monday, November 17, 2008 7:05 AM
    Tuesday, November 11, 2008 10:13 AM

All replies

  • Yep same issue here, version information below.

    Also it is a bit annoying that you get an error/warning dialog to tell you that messenger is not running for every project that you open. When you work with a few projects it is a bit unnecessary.  Could you not just inform the user in a tooltip over the disable messenger functionality?

    Thanks.


    Windows Live Messenger 
    Version 2008 Build 8.5.1302.1018

    Windows XP SP2

    Microsoft Visual Studio 2008
    Version 9.0.21022.8 RTM
    Microsoft .NET Framework
    Version 3.5

    Installed Edition: Enterprise

    Microsoft Visual Basic 2008   91904-270-7249571-60248
    Microsoft Visual Basic 2008

    Microsoft Visual C# 2008   91904-270-7249571-60248
    Microsoft Visual C# 2008

    Microsoft Visual Studio 2008 Team Explorer   91904-270-7249571-60248
    Microsoft Visual Studio 2008 Team Explorer
    Version 9.0.21022.8

    Microsoft Visual Studio 2008 Tools for Office   91904-270-7249571-60248
    Microsoft Visual Studio 2008 Tools for Office

    Microsoft Visual Studio Team System 2008 Development Edition   91904-270-7249571-60248
    Microsoft Visual Studio Team System 2008 Development Edition

    Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V.  All rights reserved.

    The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company.  Electronic version licensed from Lernout & Hauspie Speech Products N.V.  All rights reserved.


    Microsoft Visual Web Developer 2008   91904-270-7249571-60248
    Microsoft Visual Web Developer 2008

    Hotfix for Microsoft Visual Studio Team System 2008 Development Edition - ENU (KB944899)   KB944899
    This hotfix is for Microsoft Visual Studio Team System 2008 Development Edition - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/944899.

    Hotfix for Microsoft Visual Studio Team System 2008 Development Edition - ENU (KB945282)   KB945282
    This hotfix is for Microsoft Visual Studio Team System 2008 Development Edition - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/945282.

    Hotfix for Microsoft Visual Studio Team System 2008 Development Edition - ENU (KB946040)   KB946040
    This hotfix is for Microsoft Visual Studio Team System 2008 Development Edition - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/946040.

    Hotfix for Microsoft Visual Studio Team System 2008 Development Edition - ENU (KB946308)   KB946308
    This hotfix is for Microsoft Visual Studio Team System 2008 Development Edition - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/946308.

    Hotfix for Microsoft Visual Studio Team System 2008 Development Edition - ENU (KB946344)   KB946344
    This hotfix is for Microsoft Visual Studio Team System 2008 Development Edition - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/946344.

    Hotfix for Microsoft Visual Studio Team System 2008 Development Edition - ENU (KB946581)   KB946581
    This hotfix is for Microsoft Visual Studio Team System 2008 Development Edition - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/946581.

    Hotfix for Microsoft Visual Studio Team System 2008 Development Edition - ENU (KB947171)   KB947171
    This hotfix is for Microsoft Visual Studio Team System 2008 Development Edition - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/947171.

    Hotfix for Microsoft Visual Studio Team System 2008 Development Edition - ENU (KB947173)   KB947173
    This hotfix is for Microsoft Visual Studio Team System 2008 Development Edition - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/947173.

    Hotfix for Microsoft Visual Studio Team System 2008 Development Edition - ENU (KB947180)   KB947180
    This hotfix is for Microsoft Visual Studio Team System 2008 Development Edition - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/947180.

    Hotfix for Microsoft Visual Studio Team System 2008 Development Edition - ENU (KB947540)   KB947540
    This hotfix is for Microsoft Visual Studio Team System 2008 Development Edition - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/947540.

    Hotfix for Microsoft Visual Studio Team System 2008 Development Edition - ENU (KB947789)   KB947789
    This hotfix is for Microsoft Visual Studio Team System 2008 Development Edition - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/947789.

    Hotfix for Microsoft Visual Studio Team System 2008 Development Edition - ENU (KB948127)   KB948127
    This hotfix is for Microsoft Visual Studio Team System 2008 Development Edition - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/948127.

    Hotfix for Microsoft Visual Studio Team System 2008 Development Edition - ENU (KB952241)   KB952241
    This hotfix is for Microsoft Visual Studio Team System 2008 Development Edition - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/952241.

    Hotfix for Microsoft Visual Studio Team System 2008 Development Edition - ENU (KB953256)   KB953256
    This hotfix is for Microsoft Visual Studio Team System 2008 Development Edition - ENU.
    If you later install a more recent service pack, this hotfix will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/953256.

    Process Editor WIT Designer   1.4.0.0
    Process Editor for Microsoft Visual Studio Team Foundation Server, Version 1.4.0.0

    Team Foundation Server Power Tools   October 2008
    Power Tools that extend the Team Foundation Server integration with Visual Studio.

    GhostDoc for Visual Studio 2008
    For more information about GhostDoc, see the GhostDoc website
    at http://www.roland-weigelt.de/ghostdoc
    Copyright © 2003-2008 Roland Weigelt.
    Sunday, November 09, 2008 2:15 PM
  • I got the same problem and it seems to be Messenger related, I have Windows Live Messenger Beta 2009(14.0.5027.908) on Windows Vista x64 SP1.

    Per
    Monday, November 10, 2008 10:00 AM
  • I had the same issue and found the solution:

    1. Open VS 2008 and wait until Team Members is not "working..."
    2. Right-click on it and select Personal Settings
    3. Under Collaboration, click Change
    4. On the opened dialog select None and click OK
    5. Click OK once again

    HTH.
    • Proposed as answer by sgwill Tuesday, December 23, 2008 2:21 PM
    • Marked as answer by Hua Chen Thursday, August 13, 2009 5:00 AM
    Monday, November 10, 2008 2:27 PM
  • I was having the same problem.  After selecting None and clicking OK to get rid of the COM error,  I can't get back into the Team Members dialog at all.

    InvalidArgument=Value of '3' is not valid for 'SelectedIndex'
    Parameter name: SelectedIndex.

    Apparently they don't want you to choose "None". :)

    From the time I tried getting to Team Members to trying to work with it, it seems the whole feature is "almost tested".
    Monday, November 10, 2008 2:51 PM
  • I have found the PersonalSettings.xml file and deleted the   <CollaborationProvider connection="{none}" />
    line.  I can now bring up the Personal Settings dialog box again.  However I'm still stuck with this COM error since it of course defaulted back to Live Messenger as my IM provider and now I'm afraid to change anything to do with the IM setting again.

    I saw Brian's blog post today about running VS under elevated permissions vs. Messenger.  Both msnmsgr.exe and VS are both running as my user account.  I haven't done anything to explicitly elevate permissions of anything on my machine. (XP SP3, Live Messenger 8.5.1302.1018)
    Monday, November 10, 2008 3:20 PM
  • Moreauski said:

    I have found the PersonalSettings.xml file and deleted the   <CollaborationProvider connection="{none}" />
    line. 

    I'm having the same issues, but I can't find any file named PersonalSettings.xml on my PC.  Where should I be looking for that? 

    Thanks. 
    Monday, November 10, 2008 9:33 PM
  • gmford said:

    Moreauski said:

    I have found the PersonalSettings.xml file and deleted the   <CollaborationProvider connection="{none}" />
    line. 

    I'm having the same issues, but I can't find any file named PersonalSettings.xml on my PC.  Where should I be looking for that? 

    Thanks. 



    I'm also having the same problem.... If found the file here:

    C:\Documents and Settings\<user name>\Application Data\Microsoft\Team Foundation Server\PersonalSettings.config

    Mr_T [MCSD.NET, MCTS: SQL Server 2005]
    Monday, November 10, 2008 10:55 PM
  • I solved the problem after reading Brian Harry's latest post, right click on C:\Program Files (x86)\Windows Live\Messenger\msnmsgr.exe and select the Compatibility tab. Select 'Run this program as an Administrator". I've previously done the same thing to Visual Studio.

    Works fine now even though I don't like running Messenger as an administrator so maybe I'll just disable the whole Team Members stuff instead...


    Per
    • Proposed as answer by Bill.Wang Wednesday, November 12, 2008 4:38 AM
    • Marked as answer by Bill.Wang Monday, November 17, 2008 7:05 AM
    Tuesday, November 11, 2008 10:13 AM
  • I found my messenger exe here: C:\Program Files\MSN Messenger\msnmsgr.exe. I'm running Windows XP SP3 and do not have ''Run this program as an Administrator' in the compatibility tab.
    Mr_T [MCSD.NET, MCTS: SQL Server 2005]
    Wednesday, November 12, 2008 5:31 AM
  • Same error here.
    On Windows 2003 Server.
    Windows Live Messenger Version 8.1
    Wednesday, November 12, 2008 9:12 AM
  • I think we need a better solution.  I am also on XP (as is most of the business world) and so cannot 'run this program as an administrator'.  I actually installed both VS 2008 and Live Messenger myself and my account is an administrator on this machine so they should both have the permission levels?
    Wednesday, November 12, 2008 9:53 AM
  • I have the same error as well.   Note, I am running XP sp3.  I did uninstall the previous Power-Tools before installing the latested power tools.    After I clear the error, I can use Team Explorer without any problems.   Not a huge deal, just annoying.

     

     

    Wednesday, November 12, 2008 4:16 PM
  • Hi,
     
    I have XP sp2.
    I am local admin.
    I just updated to latest version of Windows Live Messager.

    Same error (just an annoyance): Creating an instance of the COM component with CLSID {B69003B3-C55E-4B48-836C-BC5946FC3B28} from the IClassFactory failed due to the following error: 8007000e.

    I related the CLSID to Live Messager in the registry.
    Anything in DCOM that can be changed as far as permissions go?
    Thursday, November 13, 2008 5:45 PM
  • Solution for Windows Server 2003:
    Goto C:\Program Files\Windows Live\Messenger, right-click on msnmsgr.exe -> Properties -> Compatibility -> Run this program in Compatibility mode -> Windows XP -> OK
    The same for C:\Program Files\Messenger\Msmsgs.exe.
    It Helped in my situation.

    P.S.: I had Windows Messenger 5.1 installed before...
    P.P.S: every team member has to have an live ID account with the same email as in the Acite Directory email of your company.
    Friday, November 21, 2008 10:33 AM
  • Hi,

    sorry for my previous post. After restarting VS the problem occured again :(.
    After 2 days of trying I found a solution (works for Win Server 2003 and Win XP).
    Tested on Windows Server 2003 with WLM 8.5 and Windows XP with WLM 9 beta.

    1. Windows Messenger 5.1  (not Live Messenger) has to be installed on the PC:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=a8d9eb73-5f8c-4b9a-940f-9157a3b3d774&displaylang=en
    2. A Live ID has to be created as in the TFS (AD account). And Microsoft Live Messenger has to be running.
    3. Open VS 2008.
    4. Error : "Creating an instance of the COM component with CLSID {B69003B3-C55E-4B48-836C-BC5946FC3B28} from IClassFactory failed due to the following error: 8007000e" -> OK
    5. Refresh Team Explorer
    6. New error: "Exception from HRESULT: 0x80040200" -> OK
    7. Refresh Team Explorer
    8. VS wants to send an error report to Microsoft -> Don't Send
    9. New error: "The server threw an exception. (Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))" -> OK
    10. Open new instance of VS 2008
    11. Repeat steps 4,5,6 on that new instance of VS 2008.
    12. Close that instance of VS 2008 and return to the old one (opened first).
    13. Refresh Team Explorer. If error occures refresh it again (1-5 times may be needed).
    14. Everything is functioning.

    P.S.: this procedure has to be done every time you open VS :(.
    Monday, November 24, 2008 9:17 AM
  • We still having problem using this "Team Member" tools and many member compliant this issues and I think we need a better solution. I think it is a technical issues and MS VS support team should address this. Most user using external Live messenger (different version) + AD account, this tools should fundamentally support this scenario.
    Benny
    Tuesday, November 25, 2008 1:37 AM
  •  I add my name to the list of people suffering from this problem.

    Come on Microsoft, let's have a solution.


    Crispin
    Thursday, November 27, 2008 3:12 PM
  • rr23121 said:

    I had the same issue and found the solution:

    1. Open VS 2008 and wait until Team Members is not "working..."
    2. Right-click on it and select Personal Settings
    3. Under Collaboration, click Change
    4. On the opened dialog select None and click OK
    5. Click OK once again

    HTH.



    This worked for me. I don't use MSN as a collaboration tool within Visual Studio so disabling it as a collaboration tool is an acceptable solution. To disable it just follow the steps outlined by rr23121 above. The only initial confusion I had was where to find "Team Members", it is located in the Team Explorer panel after expanding one of the Team Projects.

    -Igor
    • Edited by IWolbers Tuesday, December 02, 2008 2:55 PM spelling
    • Proposed as answer by B. Huard i Tuesday, December 02, 2008 10:28 PM
    Tuesday, December 02, 2008 2:53 PM
  • I think I've found _a_ solution - not necessarily the correct solution.

    I followed theses steps (as described above)

    1. Open VS 2008 and wait until Team Members is not "working..."
    2. Right-click on it and select Personal Settings
    3. Under Collaboration, click Change
    4. On the opened dialog select None and click OK
    5. Click OK once again

    But then I got this error (also described above)

    InvalidArgument=Value of '3' is not valid for 'SelectedIndex'
    Parameter name: SelectedIndex.

    I went to the PersonalSettings.config file (C:\Documents and Settings\<user name>\Application Data\Microsoft\Team Foundation Server\PersonalSettings.config) and changed the xml element from
    <CollaborationProvider connection="{none}" />
    to
    <CollaborationProvider connection="<None>" />

    No particular reason other than it matched the text in the drop down on the personal settings page, but it works.  I don't get the errors anymore and I can open the personal settings page.
    Tuesday, February 24, 2009 10:11 PM
  • Hi,

    It does not work for me.

    When I re-start VS, error shows again. Personal settings now can be opened, but instead of showing <None>, again appears Windows Live Messanger. It seems that the configuration file , even that is changed , is re-generated again.

    Also, I have Xp and if I set "Run as" administrator, it does not work for me.

    Definetly, this collaboration feature has not been well tested and can not just be uninstalled or deactivated !

    Hope anyone solves this ,

    Best,

    Carlos.

    Wednesday, February 25, 2009 11:24 PM
  • Hey all,

    Well what seems to have worked just fine for me is indeed go to PersonalSettings.config file as Ryan and others suggested, but instead of changing "{none}" to "<None>", I just changed it to an empty string like this: <CollaborationProvider connection="" />.

    This stoped VS from complaining about anything and the personal settings dialog is still available and working.

    .Yannis
    Wednesday, May 27, 2009 10:01 AM
  • Genius... it worked for me too.
    Thursday, June 11, 2009 5:52 PM
  • Thanks to all who contributed to this thread.  I had an error with the same CLSID, but the error number was 80040154.  I also wound up getting the "InvalidArgument" error when clicking on the "Personal Settings..." menuitem after I changed the setting to "{none}".  Got that resolved by editing PersonalSettings.config to use a value of empty string:  <CollaborationProvider connection="" />
    Tuesday, June 30, 2009 3:34 PM