locked
Windows Mobile Unicode Text RRS feed

  • Question

  • Hi,

    I have a really question regarding Windows Mobile unicode.  I have looked all over the forum and the internet, but did not get the exact answer I was looking for.
    I have a TextFile with Unicode Characters.  The file that I have is from here: http://www.gurbanifiles.org/special_bani/Oankaar%20(GDRE).zip (Zipped file, contains a Microsoft 03 word file)

    I want to open the file in a Windows Mobile 6.0 application, inside a textbox.
    I am currently able to open and view the file, but the Unicode characters show in squares.  I am using a Windows Mobile Emulator, because I don't own a Windows Mobile phone.

    So, once I deploy my application, will the Unicode characters display?

    Thanks,
    Harsimran Singh
    Wednesday, January 6, 2010 8:33 PM

Answers

  • Thanks for the response.

    The emulator is the English version.  The emulator is not localized.  As the font I am trying to display is not available in any of the emulator; it a type of Punjabi Unicode Font.

    Well, looks like this won't work.  If it didn't work on your PC, likely it won't work on the Smart Device.  Actually, try copy and pasting it on Notepad, thats how I got it to work.

    Another thought.....

    What if when I deploy my application?  In the Setup Project of Windows Mobile (Setup CAB project), can I add fonts in the Fonts folder.  And during installation will the fonts install during the installation of my project.  Do you think this will work?  I do see a Fonts Folder in the File System on the deployment CAB Project..  Any thoughts?

    Sorry for my newbie questions, but I just got started with Windows Mobile.  

    Thanks!
    In the Fonts Folder of the Setup CAB Project, I included the required fonts.  And I got it to work!
    Saturday, January 9, 2010 6:50 PM

All replies

  • When I open it on my desktop some of the characters display as squares. This is probably because I don't have those characters available in the fonts on my computer. Likely you are observing the same thing on your Windows Mobile emulator.  Is the emulator you are using localized for the character set you need to show?
    It takes all the running you can do to stay in one place.If you want to get somewhere else,you must try to run at least twice as fast as that.
    Thursday, January 7, 2010 12:00 AM
  • Thanks for the response.

    The emulator is the English version.  The emulator is not localized.  As the font I am trying to display is not available in any of the emulator; it a type of Punjabi Unicode Font.

    Well, looks like this won't work.  If it didn't work on your PC, likely it won't work on the Smart Device.  Actually, try copy and pasting it on Notepad, thats how I got it to work.

    Another thought.....

    What if when I deploy my application?  In the Setup Project of Windows Mobile (Setup CAB project), can I add fonts in the Fonts folder.  And during installation will the fonts install during the installation of my project.  Do you think this will work?  I do see a Fonts Folder in the File System on the deployment CAB Project..  Any thoughts?

    Sorry for my newbie questions, but I just got started with Windows Mobile.  

    Thanks!
    Thursday, January 7, 2010 12:28 AM
  • Thanks for the response.

    The emulator is the English version.  The emulator is not localized.  As the font I am trying to display is not available in any of the emulator; it a type of Punjabi Unicode Font.

    Well, looks like this won't work.  If it didn't work on your PC, likely it won't work on the Smart Device.  Actually, try copy and pasting it on Notepad, thats how I got it to work.

    Another thought.....

    What if when I deploy my application?  In the Setup Project of Windows Mobile (Setup CAB project), can I add fonts in the Fonts folder.  And during installation will the fonts install during the installation of my project.  Do you think this will work?  I do see a Fonts Folder in the File System on the deployment CAB Project..  Any thoughts?

    Sorry for my newbie questions, but I just got started with Windows Mobile.  

    Thanks!
    In the Fonts Folder of the Setup CAB Project, I included the required fonts.  And I got it to work!
    Saturday, January 9, 2010 6:50 PM