none
Report Viewer 2012 - Parameter values missing RRS feed

  • Question

  • Hi there,

    we have some reports which are created with VS 2010 Report Viewer. Now I changed the references of my project to work with Report Viewer 2012. Everything seems to work fine, but the Report Parameters are missing. The Report is created in code and this is the code for creating the list of ReportParameter:

                    List<ReportParameter> rpList = new List<ReportParameter>();                 foreach (ReportParameterInfo param in localReport.GetParameters())

                    {                    rpList.Add(new ReportParameter(param.Name, "Testvalue"));                 

                    }

                    if (rpList.Count > 0)

                        localReport.SetParameters(rpList.ToArray());

    When I use ReportViewer - Dll from VS 2010 the rendering is ok. When I use the referene to Report Viewer - Dll from 2012 (still using VS 2010) the Parameters are not shown.

    Any help is much appreciated

    Thanks

    Betina

    Friday, July 5, 2013 7:18 PM

All replies

  • I am working on a new report and cannot find the parameters menu option that is referred to in previous versions.

    So, no one has an answer for Betina?

    I thought this post would have the answer to my issues but sadly no.

    Dave

    Tuesday, July 23, 2013 6:11 PM
  • Hi,

    From the View menu, click on (Report Data), on the left you will find the Parameters.

    Regards,

    Omar

    Thursday, October 10, 2013 9:39 AM