locked
Saving draft with sender name RRS feed

  • Question

  • Hello,

    I'm connecting to Exchange server via EAS 16.1.

    When I'm saving draft message (using "Sync" command with "Add" element), the field "From" of the saved message is blank. 

    Part of request is below:

                    <Add>
                        <ClientId xmlns="AirSync:">1</ClientId>
                        <ApplicationData>
                            <Body xmlns="AirSyncBase:">
                                <Type xmlns="AirSyncBase:">1</Type>
                                <Data xmlns="AirSyncBase:">Draft body</Data>
                            </Body>
                        </ApplicationData>
                    </Add>

    Using "From" element doesn't give an effect and "Sender" element is read-only on the client.

    What element in "Sync" command should I use to save draft with sender (as it successfully OWA and Outlook do)?

    Kind regards,
    Igor

    Tuesday, November 10, 2020 4:48 PM

All replies

  • Hi Igor

    Thank you for contacting Microsoft Open Specifications. I am here to assist and research the answer for you.

    As soon as I found the answer, I will provide the update here.


    HungChun Yu (MSFT)

    Wednesday, November 11, 2020 1:03 AM
  • Hi Igor

    Question for you, which client did you ran into this issue? Could you also send a copy of the full request to dochelp at microsoft dot com and include my name Hung-chun Yu in the body of the message? 

    Thank you


    HungChun Yu (MSFT)

    Wednesday, November 11, 2020 7:46 PM
  • Hi HungChun Yu,

    I've got this issue while writing scripts to work with my Exchange server. Message to dochelp@microsoft.com with copy of request (in .xml and .wbxml formats) has been sent. 

    Best regards,

    Igor

    Friday, November 13, 2020 1:04 PM
  • Hi Igor

    Thank you for the file. 

    Could you Confirm the following:

    1. Issue does not repro if you tried to open the saved draft using outlook or OWA.

    2. Issue repro either via Desktop or Mobile Browser 

    3. Sender Name/ID in question is valid in the email server

    4. Issue also repro with other sender Name/ID not just the one presented in the sample file.


     


    HungChun Yu (MSFT)

    Friday, November 13, 2020 3:30 PM
  • Hi HungChun Yu

    About all the points:

    1. No, issue reproduces via outlook or OWA.

    2. Yes, issue reproduces via Desktop or Mobile Browser.

    3. Yes, sender Name looks valid, cause of status 1 in response. By the way, I tried a lot of different combinations of sender name.

    4. Yes, other sender name does not save on the server too.

    Monday, November 16, 2020 8:52 AM
  • Hi Igor Thank you for the confirmation.

    HungChun Yu (MSFT)

    Monday, November 16, 2020 10:02 AM
  • Hi Igor

    Let me know if you could create a test account for me and share the URL to your client, so I can further assist you with the issue.

    You can just email the test account and URL info directly to me.

    Thank you very much.



    HungChun Yu (MSFT)

    Wednesday, November 25, 2020 6:02 PM
  • Igor 

    Emailed me. Due to privacy and security concern. Test account and URL can't be provided to Microsoft to reproduce the issue.


    HungChun Yu (MSFT)

    Monday, December 7, 2020 9:15 PM