none
VS 2015 Edit Menu has two R key accelerators

    Question

  • Minor but annoying. The Edit menu has "Redo" and "Refactor" both with "R" as the accelerator key.

    Also, the Refactor menu item may or may not be present in the menu.

    When I type alt-e, r to Redo, sometimes it works and other times it doesn't, depending on if the Refactor menu item is present.

    Can this be fixed, perhaps use a different key for Refactor since R is already in use on the menu?

    Friday, February 19, 2016 8:51 PM

Answers

  • Can this be fixed, perhaps use a different key for Refactor since R is already in use on the menu?

    The accelerator key can be removed or changed. Go to menu, Tools, Customise, then to Commands tab, select “Menu bar: Edit”. If you rarely need the key for Refactor, then select “Refactor”, click “Modify Selection”, and then remove “&” from the name. Or you can move “&” to different place and use another name for this menu item.


    Saturday, February 20, 2016 7:44 AM

All replies

  • You can modify the shortcuts in VS in the Options -> Keybord -> Edition-Redo as described in this MSDN article:https://msdn.microsoft.com/en-us/library/5zwses53.aspx



    You can even share you keyboard shortcuts modifications with friends in need :)... by exporting your options settings...neat!
    Friday, February 19, 2016 9:41 PM
  • Thanks for the reply.

    It's not the keyboard shortcut that's the problem. Keyboard shortcut for Redo is Ctrl-Y, Refactor has no shortcut.

    I'm not using the keyboard shortcut, I'm using the menu accelerator keys.

    Alt-E - brings up the Edit menu, R selects Redo on the Edit menu.

    The issue is that if Refactor is also in the Edit menu then R no longer selects Redo.

    Friday, February 19, 2016 9:55 PM
  • Rigth, testing it shows you need to hit "Alt-E R R" to get to Refactor as it is the second R shortcut...

    So Alt-E R is Redo

    AltE R R is Refactor...

    Friday, February 19, 2016 10:01 PM
  • Can this be fixed, perhaps use a different key for Refactor since R is already in use on the menu?

    The accelerator key can be removed or changed. Go to menu, Tools, Customise, then to Commands tab, select “Menu bar: Edit”. If you rarely need the key for Refactor, then select “Refactor”, click “Modify Selection”, and then remove “&” from the name. Or you can move “&” to different place and use another name for this menu item.


    Saturday, February 20, 2016 7:44 AM