none
"Microsoft.ACE.OLEDB.12.0 Provider is not registered on the local machine" RRS feed

  • Question

  • Hi All,

    I'm developing a project that connects to an Access 2007 database via an OLEDB conncection. When connecting I get the following error: "Microsoft.ACE.OLEDB.12.0 Provider is not registered on the local machine".

    I've just updated to a 64-bit machine and done the following to fix this:
    1) downloaded and installed the Office 2007 Data Connectivity Compoents
    2) changed the Active Solution Platform in VS2005 to x86

    The connection string is "Provider=Microsoft.ACE.OLEDB.12.0;Data Source=c:\in2food\in2food.accdb"

    Is there anything else that needs to be done?

    Thanks for your help.

    KP
    Monday, January 5, 2009 5:53 PM

Answers

  • That should be it. As long as you've compiled your app for 32-bit then this should work. Have you verified that your app is not running as a 64-bit process?


    Paul ~~~~ Microsoft MVP (Visual Basic)
    • Marked as answer by djcheez Monday, January 5, 2009 9:45 PM
    Monday, January 5, 2009 7:23 PM

All replies

  • That should be it. As long as you've compiled your app for 32-bit then this should work. Have you verified that your app is not running as a 64-bit process?


    Paul ~~~~ Microsoft MVP (Visual Basic)
    • Marked as answer by djcheez Monday, January 5, 2009 9:45 PM
    Monday, January 5, 2009 7:23 PM
  •  How do I verify? I thought that once the platform is changed to x86 and the app is rebuilt and launched, it should run as a 32-bit process.

    I know I'm missing something simple. But what?

    KP
    Monday, January 5, 2009 9:33 PM
  • Thanks Paul - I stumbled on the solution. My project is in multiple pieces, so I had to change the project settings to reflect the x86 platform for each of them.

    KP
    Monday, January 5, 2009 9:47 PM
  • OK, I'm having the same problem.  I went into the projects properties and set the Target CPU to x86.  Is there another location where I need to change this?  How can I know for sure that the program is compiled in x86.  This is driving me nuts, any help would be appreciated.
    Wednesday, March 25, 2009 8:23 PM