locked
URGENT: The command failed because the database mirror is busy! RRS feed

  • Question

  • Hi,

     

    Mirroring has been working fine on 2 identical servers. We even tested failover and that worked....but today something happened (still investigating) and suddenly the Principal is disconnected and we cannot force failover with:

     

    ALTER DATABASE [LeoCTI] SET PARTNER FORCE_SERVICE_ALLOW_DATA_LOSS

     

    Error: The command failed because the database mirror is busy! Try again later!

     

    How can I bring the principal back online? It won't let me do anything, won't let me turn off mirroring etc. etc.

     

    HELP PLEASE!

     

    Thanks

    Hyper aka Richard

    Friday, March 30, 2007 11:06 AM

All replies

  • Hello all,

     

    I figured out that the connection between our two servers was not good enough to support mirroring and mirroring kept timing out (you can see this in the log).  I  managed to run this on the mirror (state: synchronizing/restoring):

     

    alter database <db name> set partner off

     

    and then waited about 20/30 minutes and was able to backup the log and restore it on the principal and then re-enable mirroring.

     

    Lesson learned:

    1. make sure connections between mirrored servers are good

    2. if prinicpal fails, need to be PATIENT and first turn off mirroring on the partner (ie. mirror) so it can be used (otherwise it just sits in the synchronizing/restoring state)

     

    Friday, March 30, 2007 4:38 PM
  • I have the exact same issue.  Mirroring worked great until I moved the mirror server to another location over a metro e 10mbps connection.  Even at that speed it would not work correctly.  We are going to a 50mbps connection, but I have lost all confidence in this over a WAN.  I know they say they dont support it, but it also is very frustrating that the DB becomes corrupt in this state to where you can not do anything. 

    Monday, June 23, 2008 3:23 PM