none
Biztalk 2010 to CRM 2011 On-premise integration binding problem RRS feed

  • Question

  • Hi Experts,

    I am doing one demo to connect to crm 2011 from BizTalk 2010 by following below resources.

    Source: Packtpub.Microsoft.BizTalk LOB Integration pdf book
    chapter:Chapter 3.

    Scenario: Working on a project to send messages from biztalk 2010 to crm 2011 on-premise ,I have been stuck with the below mentioned error:

    The adapter failed to transmit message going to send port

    "WcfSendPort_OrganizationService_CustomBinding_IOrganizationService_Custom" with URL

    "http://mycrmbox:6666/MyOrg/XRMServices/2011/Organization.svc". It will be retransmitted

    after the retry interval specified for this Send Port.

    Details:"System.ServiceModel.Security.SecurityNegotiationException: The caller was not authenticated

    by the service. ---> System.ServiceModel.FaultException: The request for security token could not be

    satisfied because authentication failed.
       at System.ServiceModel.Security.SecurityUtils.ThrowIfNegotiationFault(Message message,

    EndpointAddress target)
       at System.ServiceModel.Security.SspiNegotiationTokenProvider.GetNextOutgoingMessageBody(Message

    incomingMessage, SspiNegotiationTokenProviderState sspiState)
       --- End of inner exception stack trace ---

    Server stack trace: 
       at System.ServiceModel.Security.IssuanceTokenProviderBase`1.DoNegotiation(TimeSpan timeout)
       at System.ServiceModel.Security.SspiNegotiationTokenProvider.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Security.WrapperSecurityCommunicationObject.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.Security.CommunicationObjectSecurityTokenProvider.Open(TimeSpan timeout)
       at System.ServiceModel.Security.SymmetricSecurityProtocol.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Security.WrapperSecurityCommunicationObject.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.Channels.SecurityChannelFactory`1.ClientSecurityChannel`1.OnOpen(TimeSpan

    timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open()

    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage

    retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at System.ServiceModel.ICommunicationObject.Open()
       at Microsoft.BizTalk.Adapter.Wcf.Runtime.WcfClient`2.GetChannel[TChannel](IBaseMessage

    bizTalkMessage, ChannelFactory`1& cachedFactory)
       at Microsoft.BizTalk.Adapter.Wcf.Runtime.WcfClient`2.SendMessage(IBaseMessage bizTalkMessage)".

    Can somebody explain the bindings?

    Thanking You

    Friday, February 22, 2013 1:37 PM

All replies

  • I was a technical reviewer for the book so I am glad to try to help with this.

    I looked back at the chapter quickly (I could have missed something), but did not see anything about the credentials/authentication. Here is a related blog post the chapter author did: http://seroter.wordpress.com/2011/02/10/the-good-bad-and-ugly-of-integrating-dynamics-crm-2011-and-biztalk-server-2010/. In this post he mentions he used a Windows credential in the port. What type of credential are you using?

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline

    Saturday, February 23, 2013 4:08 PM
    Moderator
  • Hi Ben,

    Thanks for reply.

    I just added my CRM 2011 server Admin Username and password to the credential tab of my sending port.

    Expecting some more suggestion to resolve my issue.

    Thanking You.


    • Edited by Ashis_K Monday, February 25, 2013 7:45 AM
    Monday, February 25, 2013 6:29 AM
  • Hi Experts,

    Actually I am using two domains,in one domain my CRM 2011 is there and in other Biztalk. So I have followed all the procedure to connect to CRM 2011 but still getting same above error.

    Also I followed the link given by Ben ,but getting same error.


    Tuesday, February 26, 2013 4:38 AM
  • I would assume that the book sample is using the same domain. So in your case I am not sure that the cross domain authentication will be possible.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline

    Monday, March 4, 2013 4:26 PM
    Moderator
  • Greetings People,

    Anybody found a solution to this???

    its quite frustrating as we followed the steps to the letter

    Thursday, December 19, 2013 2:56 PM