locked
sharepoint 2010 does NOT SUPPORT PDF FILE In appliction page ? WHY? RRS feed

  • Question

  • I AM USED SHAREPOINT2010 AND CREATE A APPLICATION PAGE IN ASPX THAT TIME RETRIEVE PDF FILE TO GRIDVIEW DOES NOT WORK THIS ERROR CAME HOW CAN I SOLVE?
    • Edited by arunjintha Friday, July 13, 2012 8:38 PM
    Friday, July 13, 2012 6:51 PM

Answers

  • Hi arunjintha,

    Application page is just an ASP.NET page with some SharePoint page direction. If the code you are using works in a standard ASP.NET page, then it will work in SharePoint application page too.

    Just from the error message you posted, seems there are some invalid character in the page. I would suggest you reviewing the application page, ensure all Start Tag and End Tag are matched, and then have a try again.

    Thanks,
    Jinchun Chen


    Jinchun Chen
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff AT microsoft.com(Please replace AT with @)

    • Marked as answer by Pengyu Zhao Thursday, August 9, 2012 1:31 AM
    Tuesday, July 17, 2012 9:48 AM

All replies

  • <wijmo:C1GridView ID="C1GridView_pdf" runat="server" 
                                              DataKeyNames="sample_image_id" AutoGenerateColumns="False" ShowFooter="False">
                                    <Columns>
                                     <wijmo:C1TemplateField HeaderText="pdfname" >
                                    <ItemTemplate>
                                    <%#Eval("pdfname")%>
                                    </ItemTemplate>
                                   </wijmo:C1TemplateField>
                                   <wijmo:C1TemplateField HeaderText="pdf">
                                   <ItemTemplate>
                                    <asp:HyperLink Target="_blank" ID="HyperLink1" runat="server"  NavigateUrl=' <%# "~/_layouts/WebPdm/viewpdf.aspx?ID=" + Eval("sample_image_id", "{0:d}")%> ' ToolTip='<%# DataBinder.Eval(Container.DataItem,"sample") %>'><%#Eval("PDFNAME") %></asp:HyperLink>                                                           
                                   </ItemTemplate>
                                     </wijmo:C1TemplateField>
                                    </Columns>
                                    </wijmo:C1GridView>

    I RETRIEVE THE PDF FILE IN VISUALSTUDIO 2010? WHY DOES NOT RETRIEVE IN SHAREPOINT2010?


    • Edited by arunjintha Friday, July 13, 2012 8:39 PM
    Friday, July 13, 2012 7:02 PM
  • Hi arunjintha,

    Application page is just an ASP.NET page with some SharePoint page direction. If the code you are using works in a standard ASP.NET page, then it will work in SharePoint application page too.

    Just from the error message you posted, seems there are some invalid character in the page. I would suggest you reviewing the application page, ensure all Start Tag and End Tag are matched, and then have a try again.

    Thanks,
    Jinchun Chen


    Jinchun Chen
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff AT microsoft.com(Please replace AT with @)

    • Marked as answer by Pengyu Zhao Thursday, August 9, 2012 1:31 AM
    Tuesday, July 17, 2012 9:48 AM