none
.net framework 4.0 code 641 RRS feed

  • Question

  • Been having issues installing framework 4.0 since about march. 3 clean installs (Windows 7 x64) later and the problem still exists.

    tried all fixes i could find here and elsewhere to no avail.

    - Cleaning up using the cleanup tool

    - Running Microsoft FixIt

    - Running as administrator

    - Downloading/installing the standalone package from the Microsoft site

    - Turning off antivirus

    - Cleaning all temp folders

    posting the link to my vslog.cab hoping someone can narrow down the problem.

    Thanks in advance.

    https://skydrive.live.com/redir?resid=798415230D7F5765!107


    • Edited by JLoum Saturday, June 2, 2012 10:07 PM
    Saturday, June 2, 2012 9:28 PM

Answers

All replies

  • There is no .NET Frmework 4.0 log in your vslogs. Is it possible you cleaned your %temp% directory after the last try?

    As we are starting over, pleas try this sequence:

    Follow these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Sunday, June 3, 2012 1:57 PM
  • Followed the directions and still failed, still no html log from .net framework 4.0 in vslog.cab

    here's the screenshot from failed install, another installation is already in progress?screenshot

    new vslog.cab on skydrive


    • Edited by JLoum Sunday, June 3, 2012 11:48 PM
    Sunday, June 3, 2012 11:46 PM
  • The message "Another installation is already in progress" indicated a Windows Installer issue on your system.

    The Windows Installer is not designed to support multiple concurrent installetions and yours "thinks" another install is still running. That explains the lack of a .NET Framework 4.0 install log. The install never started.

    Here are a couple of things you can try to clear your WI issue:

    http://support.microsoft.com/kb/2438651

    http://support.microsoft.com/kb/907749

    This is one of many Windows Installer repair threads found in the Microsoft Answers forums for Windows 7:

    http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/how-do-i-instantly-repair-windows-installer/a51b007a-f85f-4fd5-a77e-3561b6ca505a

    Monday, June 4, 2012 1:57 AM