none
bcdboot does not work in Hyper-V RRS feed

  • Question

  • Hi,

    I used a "Windows PE.vhd" to boot my virtual machine in the Hyper-V. 

    My virtual machine has another VHD into which, I unpacked the content of a WIM file. THe WIM file contains the image of a working Windows Server 2008 R2 installation.

    I partitioned this VHD with diskpart as following:

    par 1   100 MB  fat32  c:

    par 2     127 GB NTFS D:  (contains the unpacked WS2008 R2 image)

    Now I stopped my virtual machine. I disattached the "Win PE.vhd". And I tried to boot from the just prepared new VHD. But it did not work.

     

    I tried several tests.

     

    I used: 

             bcdboot d:\Windows /s c:

             bcdboot d:\Windows             ==> this one raised a straing error message   C0000098

     

    I also tried making the 100 MB as the active partition

    as well making the 127 GB partition the active one.

     

    .... ant a lot of l further test ( 100 MB partition with NTFS instead of FAT32,  ..... )

     

    No one of my attempts succceded. I was not able to boot from my "WS 2008 R2. vhd".

     

    Does somebody know how to make a "WS 2008 R2.vhd" (R2 is always x64 ) bootable in the Hype-V?

     

         Thanks in advance for your help.  

     

     

     

     

     

     

     

     

    Tuesday, December 6, 2011 4:31 PM