locked
Crash when using intellisense with a lot of references in Nodejs project RRS feed

  • Question

  • User-1629503944 posted

    I've been using references a lot to get Intellisense to "know" about all my scripts that have important variables and functions. To make this easy, I've been including a single reference on all of my scripts:

     

    /// <reference file="./../references.js" />
    

     

    references.js is a script that is never run. All it does is contain all my other references I want to use so that they will be populated into Intellisense. With 9 references included in my references.js, everything works fine. But once I add a tenth, things start to bug out; One of those references will no longer be processed into Intellisense, and if I try to edit the script that's not being processed (and try to use Intellisense on it), it waits a bit and then crashes WebMatrix.

    I don't know much about debugging this type of thing, but my only idea about what it might be is it could be recursively including those references and hitting some max references limit.

     

    (Apologies if this isn't the correct place to report bugs)

    Thursday, September 6, 2012 7:57 PM

Answers

  • User-1785435100 posted

    Would you be able to send me a sample of the code that is failing ? You could email it to vinelap@microsoft.com.

    It is hard to tell what is going on without looking at the WebMatrix stack trace.

     Thanks,

    Vinela

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, September 12, 2012 12:47 PM

All replies

  • User-1785435100 posted

    Thanks for reporting the issue. Could you provide a stack trace from the event viewer logs ?

     -Vinela

    Monday, September 10, 2012 1:15 PM
  • User-1629503944 posted

    Here's one event:
    ------------------------

    Log Name:      Application
    Source:        Windows Error Reporting
    Date:          9/10/2012 9:44:19 PM
    Event ID:      1001
    Task Category: None
    Level:         Information
    Keywords:      Classic
    User:          N/A
    Description:
    Fault bucket , type 0
    Event Name: APPCRASH
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: WebMatrix.exe
    P2: 7.1.1674.0
    P3: 503704f5
    P4: clr.dll
    P5: 4.0.30319.269
    P6: 4ee9ae83
    P7: c00000fd
    P8: 00194cc5
    P9:
    P10:

    Attached files:

    These files may be available here:
    C:\Users\bob\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_WebMatrix.exe_549d7f7f60d5aebf823ba2347bc245a3b3d39d8_0ccbc552

    Analysis symbol:
    Rechecking for solution: 0
    Report Id: 30e2d086-fbb2-11e1-8cde-ed09b7df97f5
    Report Status: 0
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Windows Error Reporting" />
        <EventID Qualifiers="0">1001</EventID>
        <Level>4</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-09-11T01:44:19.000000000Z" />
        <EventRecordID>100406</EventRecordID>
        <Channel>Application</Channel>
        <Security />
      </System>
      <EventData>
        <Data>
        </Data>
        <Data>0</Data>
        <Data>APPCRASH</Data>
        <Data>Not available</Data>
        <Data>0</Data>
        <Data>WebMatrix.exe</Data>
        <Data>7.1.1674.0</Data>
        <Data>503704f5</Data>
        <Data>clr.dll</Data>
        <Data>4.0.30319.269</Data>
        <Data>4ee9ae83</Data>
        <Data>c00000fd</Data>
        <Data>00194cc5</Data>
        <Data>
        </Data>
        <Data>
        </Data>
        <Data>
        </Data>
        <Data>C:\Users\bob\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_WebMatrix.exe_549d7f7f60d5aebf823ba2347bc245a3b3d39d8_0ccbc552</Data>
        <Data>
        </Data>
        <Data>0</Data>
        <Data>30e2d086-fbb2-11e1-8cde-ed09b7df97f5</Data>
        <Data>0</Data>
      </EventData>
    </Event>

    ---------------------

    I've uploaded the Report.wer that's listed under attached files here: http://pastebin.com/fyJuBL2C

    And here's another:
    ---------------------

    Log Name:      Application
    Source:        Application Error
    Date:          9/10/2012 9:44:15 PM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Description:
    Faulting application name: WebMatrix.exe, version: 7.1.1674.0, time stamp: 0x503704f5
    Faulting module name: clr.dll, version: 4.0.30319.269, time stamp: 0x4ee9ae83
    Exception code: 0xc00000fd
    Fault offset: 0x00194cc5
    Faulting process id: 0x11d0
    Faulting application start time: 0x01cd8fbde090dc6e
    Faulting application path: C:\Program Files (x86)\Microsoft WebMatrix\WebMatrix.exe
    Faulting module path: C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll
    Report Id: 30e2d086-fbb2-11e1-8cde-ed09b7df97f5
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-09-11T01:44:15.000000000Z" />
        <EventRecordID>100405</EventRecordID>
        <Channel>Application</Channel>
        <Security />
      </System>
      <EventData>
        <Data>WebMatrix.exe</Data>
        <Data>7.1.1674.0</Data>
        <Data>503704f5</Data>
        <Data>clr.dll</Data>
        <Data>4.0.30319.269</Data>
        <Data>4ee9ae83</Data>
        <Data>c00000fd</Data>
        <Data>00194cc5</Data>
        <Data>11d0</Data>
        <Data>01cd8fbde090dc6e</Data>
        <Data>C:\Program Files (x86)\Microsoft WebMatrix\WebMatrix.exe</Data>
        <Data>C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll</Data>
        <Data>30e2d086-fbb2-11e1-8cde-ed09b7df97f5</Data>
      </EventData>
    </Event>

     ---------------------

    Let me know if I've missed anything that I should be including. I've never done anything with the event viewer before. I took out Computer on these since it's probably not needed.

    Monday, September 10, 2012 10:09 PM
  • User-1785435100 posted

    Would you be able to send me a sample of the code that is failing ? You could email it to vinelap@microsoft.com.

    It is hard to tell what is going on without looking at the WebMatrix stack trace.

     Thanks,

    Vinela

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, September 12, 2012 12:47 PM
  • User-1629503944 posted

    Alright. I've sent you an email with a sample project and some steps to reproduce this.

    Wednesday, September 12, 2012 10:50 PM
  • User-1785435100 posted

    Thanks for the repro! We are looking into the issue.

     -Vinela

    Thursday, September 13, 2012 8:04 PM