none
How to disable telemetry for SSRS 2017? RRS feed

  • Question

  • I'm not able to figure out how to disable telemetry for my SSRS 2017 installation. I do not want my SSRS instance talking to msecnd.net / setting application insights cookies on my domain.

    I've tried adding "EnableTelemetry=false" to the ReportViewerHost control but I believe this is applicable for the ReportViewer classes (not running inside SSRS) only.

    <RS:ReportViewerHost ID="ReportViewerControl" KeepSessionAlive="false" EnableTelemetry="false" runat="server" />

    I'm running version 14.0.600.

    Thanks,

    Bob

    Friday, March 30, 2018 9:45 PM

All replies

  • Hi Bob,

    In your scenario, it seems that you can't want the SSRS to collect your information, right?

    As I know, we could use EnableTelemetry=false in report viewer control like below

    \<rsweb:ReportViewer ID="ReportViewer1" runat="server" EnableTelemetry="false">
    \</rsweb:ReportViewer>

    You could refer to Integrating Reporting Services Using ReportViewer Controls - Data Collection for details.

    In SQL Server, you also could enable or disable usage feedback collection in SSMS. And we could disable the sending of information to Microsoft only in paid versions of SQL Server. You could refer to How to configure SQL Server 2016 or later to send feedback to Microsoft and this blog for details.

    Best Regards,
    Zoe Zhi

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, April 2, 2018 2:02 AM
    Moderator
  • Zoe,

    Thanks for your reply. I'm not using the report viewer control that is distributed directly, I'm using standard reporting services (part of SQL Server; now released on a separate schedule).

    I tried EnableTelemetry="false" but that doesn't seem to disable telemetry for the report viewer that is shipped as part of SQL Server.

    Thanks,

    Bob

    Monday, April 2, 2018 1:22 PM
  • hi Bob,

    Please refer to "Choice/Control" in https://www.microsoft.com/EN-US/privacystatement/SQLServer/Default.aspx to disable telemetry on RS2017.


    This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, April 6, 2018 9:47 PM
  • Thanks! I changed the registry key

    HKLM/SOFTWARE/Microsoft/Microsoft SQL Server/SSRS/CPE/CustomerFeedback

    to 0 and that fixed my problem.

    Thursday, April 12, 2018 5:37 PM
  • Hi Bob A,

    It seems that you have solved your issue, right? If so and if you'd like to, you could mark corresponding post as answer or share your solutions. That way, people who in this forum and have similar issue will benefit from it.

    Thanks for your understanding and support.
    Best Regards,
    Zoe Zhi

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, April 16, 2018 6:24 AM
    Moderator