none
HTML displaying as a single line RRS feed

  • Question

  • At times, I will have multiple web pages suddenly display all the HTML on one, single continuous line. Of course, this does not affect how it displays in a browser or in the design view but does make it extremely difficult to edit in the code window. I have had this happen on more than one occasion. I normally edit the webs "live" and publish down locally but this last time it happened while editing the "local" copy (27 pages) on my computer and before it was FTP'd up to the domain. Most of the pages were affected but not all. I am using a DWT. I normally do not use the "publish" feature and prefer to use a stand-alone FTP program. I do not have the "optimize html" feature activated but after the fact I did try to use the publish feature and had the optimize feature active including "remove white space", both leading and all html. This did not correct the issue.

    EW ver. 4.0.130.0 SP2, purchased, licensed and activated

    1) how to prevent this from happening?
    2) any way to recover the original formatting without doing it manually?

    Experience level: started with FP98, had FP2K, EW3 and now EW4 with ~15 domains.

    Monday, October 7, 2013 9:21 PM

Answers

  • Not sure why it is happening, but to recover your formatting, just right-click in code view, then scroll down and click "Reformat HTML." That will get you back to a workable page.  ;-)

    As you may know, very few here, if any, would recommended editing live on the server. Best practice is to edit locally, test in multiple browsers for cross-browser compatibility, and only then publish to the remote server. Also, although previous versions of EW left more than a little to be desired in this regard, site management and FTP publishing in EW4 SP2 are really stable and well implemented. Might want to adopt a consistent workflow using EW's facilities and see if that ameliorates your problem...

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    • Edited by paladyn Monday, October 7, 2013 9:41 PM
    • Marked as answer by Idaspode Monday, October 7, 2013 10:55 PM
    Monday, October 7, 2013 9:35 PM
  • If you have "optimized" selected for publishing in the site settings, that will happen to pages edited locally, then published (Optimizing causes, not cures, this issue).  If that's the reason, the cure is simple: don't do that.  It doesn't save enough size/bandwidth to be worth the mess it makes of reading the markup.  If that's not the reason, your guess is as good as mine: that's the only time EW will do this.  If your FTP program has such an optimize feature, make sure it is off, as well.  (And if it's your FTP program that is doing it, it's not really an EW topic.)

    As Scott points out, EW can reformatt the HTML for you and undo the effect.

    • Edited by KathyW2 Monday, October 7, 2013 10:11 PM
    • Marked as answer by Idaspode Monday, October 7, 2013 10:55 PM
    Monday, October 7, 2013 10:08 PM

All replies

  • Not sure why it is happening, but to recover your formatting, just right-click in code view, then scroll down and click "Reformat HTML." That will get you back to a workable page.  ;-)

    As you may know, very few here, if any, would recommended editing live on the server. Best practice is to edit locally, test in multiple browsers for cross-browser compatibility, and only then publish to the remote server. Also, although previous versions of EW left more than a little to be desired in this regard, site management and FTP publishing in EW4 SP2 are really stable and well implemented. Might want to adopt a consistent workflow using EW's facilities and see if that ameliorates your problem...

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    • Edited by paladyn Monday, October 7, 2013 9:41 PM
    • Marked as answer by Idaspode Monday, October 7, 2013 10:55 PM
    Monday, October 7, 2013 9:35 PM
  • If you have "optimized" selected for publishing in the site settings, that will happen to pages edited locally, then published (Optimizing causes, not cures, this issue).  If that's the reason, the cure is simple: don't do that.  It doesn't save enough size/bandwidth to be worth the mess it makes of reading the markup.  If that's not the reason, your guess is as good as mine: that's the only time EW will do this.  If your FTP program has such an optimize feature, make sure it is off, as well.  (And if it's your FTP program that is doing it, it's not really an EW topic.)

    As Scott points out, EW can reformatt the HTML for you and undo the effect.

    • Edited by KathyW2 Monday, October 7, 2013 10:11 PM
    • Marked as answer by Idaspode Monday, October 7, 2013 10:55 PM
    Monday, October 7, 2013 10:08 PM
  • Thank you very much Scott and Kathy. (I assume you are the same KathyW on Usenet?)

    I will chide myself for not exploring the right click options, that fixed it!

    I guess I got into the edit live practice on earlier versions although even with EW4, most times it works as designed, sometimes not. I use Fire FTP, I don't think it contains an option to alter/optimize.

    I was working on my local copy this time. This particular issue occurred when I simply copied the whole web to another folder on my computer, but I didn't catch it until I uploaded the web.

    Scott, I learned a new word today, I had to look up ameliorate... :)

    Again, thank both of you, over and out.

    David

    Monday, October 7, 2013 11:13 PM