none
HCK USB Descriptor Test failed RRS feed

  • Question

  • I'm trying to run the HCK USB tests against a touch device. My test machine has USB 2.0 and USB 3.0 and the touch device is connected via the USB 3.0 port. But the USB tests failed with the following error:

    Start: RunUsbTest, TUID=
    Device test of instance path: USB\VID_2465&PID_0900&REV_0300\1&79F5D87&0&907352403
    Device is connected to the system
    Device instance path not found, trying VID/PID match
    Note: For this test, the device must be tested behind an xHCI controller.
    Error: Terminating: USB\VID_2465&PID_0900 not found.
    End: Fail, RunUsbTest, TUID=, Repro=

    Why is it throwing this error and how can I fix it?

    Thanks.

    Thursday, April 11, 2013 12:01 AM

All replies

  • Hi PhyllisL,

    Could you confirm your USB3.0 port is enabled on Device Manager?

    Your xHCI contoroller name will help us to find problems.

    Thanks

    YoYamada

    Thursday, April 11, 2013 11:59 PM
  • I can see the USB3.0 port in Device Manager. It's 'Renesas USB 3.0 eXtensible Host Controller -0096 (Microsoft)'.

    Friday, April 12, 2013 6:29 PM
  • Any ideas?
    Tuesday, April 16, 2013 4:39 PM
  • When plugging your USB device to USB3.0 port on PC, can you find your device on the xHCI controller on Device Manager?

    Wednesday, April 17, 2013 1:22 AM
  • What does that mean and what should I look for? In Device Manager, even if I plug the keyboard in the USB3.0 port, I don't see anything shows up under the xHCI controller.
    Thursday, April 25, 2013 5:52 PM
  • I'm still looking for a solution to the problem I'm having. Does anyone have more detailed/specific suggestions that I can try out?
    Friday, May 3, 2013 10:13 PM
  • My test system has only EHCI port . can we pass descripter test without using xhci controller???
    Monday, September 15, 2014 4:11 PM