locked
Cannot Login with IP RRS feed

  • Question

  • Hi all, I trying to Login in Microsoft SQL Server Management Studio, The problem is I cannot Login with my IP as a Server Name (127.0.0.1 or my Local IP), its always give me this error:

    Arithmetic operation resulted in an overflow. (System.Data)

    but I still can login with localhost, but I require connection with IP, because for Database Game Online and My Server Program for Host the Game even cannot connect to database (Before this error occured, my server program can connect with IP as server name) . I ever meet this error before in few months ago, but I end up by ReInstalling my Windows, I am login using Mixed SQL Server Authentication.

    Now its no way to Reinstall my Windows again -_-" Please help me...

    Sorry if my English so bad, Thanks!

    Monday, June 4, 2012 2:52 AM

Answers

  • Hi AmateriaImpure,

    According to the error message ,please refer to this online article How to Troubleshoot Connecting to the SQL Server Database Engine.


    Best Regards,
    Peja

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Peja Tao Friday, June 8, 2012 7:21 AM
    Tuesday, June 5, 2012 1:59 AM

All replies

  • Hello,

    Reinstalling Windows won't change anything. You have to add the IP port as well. If e.g. the IP port of your SQL Server instance is 1433, then you have to use:

    tcp:127.0.0.1, 1433

    as server name to logon.


    Olaf Helper
    * cogito ergo sum * errare humanum est * quote erat demonstrandum *
    Wenn ich denke, ist das ein Fehler und das beweise ich täglich
    Blog Xing

    Monday, June 4, 2012 5:04 AM
  • Hi,

      What is the actual SQL Server name given during the installation. Is it the default instance or named instance ?

     Have you given Server name like "yourIP\MSSQL" or "yourIP\SQLEXPRESS", if that is the case then you need to give in the same way to connect to MSSQL server.

    Also please refer to the discussion thread:

    http://social.msdn.microsoft.com/Forums/en-US/sqlgetstarted/thread/60b68c17-504f-405a-ae12-9a83a4e91d6b


    -- Reddy Balaji C. ##Mark as answer if it solves the issue

    Monday, June 4, 2012 5:07 AM
  • Hello,

    Reinstalling Windows won't change anything. You have to add the IP port as well. If e.g. the IP port of your SQL Server instance is 1433, then you have to use:

    tcp:127.0.0.1, 1433

    as server name to logon.


    Olaf Helper
    * cogito ergo sum * errare humanum est * quote erat demonstrandum *
    Wenn ich denke, ist das ein Fehler und das beweise ich täglich
    Blog Xing

    I ever meet this problem and when I reinstall my windows, its solved.

    I tried that, still have same error.

    Monday, June 4, 2012 5:53 AM
  • Hi,

      What is the actual SQL Server name given during the installation. Is it the default instance or named instance ?

     Have you given Server name like "yourIP\MSSQL" or "yourIP\SQLEXPRESS", if that is the case then you need to give in the same way to connect to MSSQL server.

    Also please refer to the discussion thread:

    http://social.msdn.microsoft.com/Forums/en-US/sqlgetstarted/thread/60b68c17-504f-405a-ae12-9a83a4e91d6b


    -- Reddy Balaji C. ##Mark as answer if it solves the issue

    As I Said, I am using Mixed SQL Server Authentication. That mean I am using MSSQLSERVER (default instance), I already tried it, but give me this error:

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (.Net SqlClient Data Provider)

    I already enabled the Named Pipes, Shared Memory and TCP/IP, I already set Listen All in TCP/IP, I also already disable my Firewall but still have same error like that.

    Btw, that is my old thread, like I said before, I ever meet this error, but none of that answer is solving this problem.



    • Edited by ChronO2Jam Monday, June 4, 2012 6:02 AM
    Monday, June 4, 2012 5:58 AM
  • >>>As I Said, I am using Mixed SQL Server Authentication. That mean I am using MSSQLSERVER (default instance), I already tried it, but >>>>give me this error:

    You can have a named instance to use Mixed Authentication , does not relate to default instance.

    Can you check if the MS SQL Service is running up? Verify that  you typed the server name correctly.


    Best Regards, Uri Dimant SQL Server MVP http://dimantdatabasesolutions.blogspot.com/ http://sqlblog.com/blogs/uri_dimant/

    Monday, June 4, 2012 6:31 AM
    Answerer
  • >>>As I Said, I am using Mixed SQL Server Authentication. That mean I am using MSSQLSERVER (default instance), I already tried it, but >>>>give me this error:

    You can have a named instance to use Mixed Authentication , does not relate to default instance.

    Can you check if the MS SQL Service is running up? Verify that  you typed the server name correctly.


    Best Regards, Uri Dimant SQL Server MVP http://dimantdatabasesolutions.blogspot.com/ http://sqlblog.com/blogs/uri_dimant/

    I am using default Instance, I am NOT using SQLEXPRESS or any named instance, I just select default Instance when I Installing. I already tried login with 127.0.0.1/MSSQL and 127.0.0.1/MSSQLSERVER but got this error:

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (.Net SqlClient Data Provider)

    Thanks for the reply.




    • Edited by ChronO2Jam Monday, June 4, 2012 7:06 AM
    Monday, June 4, 2012 6:46 AM
  • Try connect localhost  or just name of computer without slashes 

    Best Regards, Uri Dimant SQL Server MVP http://dimantdatabasesolutions.blogspot.com/ http://sqlblog.com/blogs/uri_dimant/

    Monday, June 4, 2012 7:26 AM
    Answerer
  • Create a alias name and try to login.

    TO CREATE ALIAS

    1. In SQL Server Configuration Manager, expand SQL Server Native Client Configuration, right-click Aliases, and then click New Alias.

    2. In the Alias Name box, type the name of the alias. Client applications use this name when they connect.

    3. In the Server box, type the name or IP address of a server. For a named instance append the instance name.

    4. In the Protocol box, select the protocol used for this alias. Selecting a protocol, changes the title of the optional properties box to Port No, Pipe Name, or Connection String.

    Monday, June 4, 2012 12:08 PM
  • Hi AmateriaImpure,

    According to the error message ,please refer to this online article How to Troubleshoot Connecting to the SQL Server Database Engine.


    Best Regards,
    Peja

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Peja Tao Friday, June 8, 2012 7:21 AM
    Tuesday, June 5, 2012 1:59 AM