locked
Query is not run properly RRS feed

  • Question

  • hi, All

    Hear is my MS-Sql 2008 Express Query

     

    Provider=SQLNCLI10.1;Data Source=HITESH-PC\SQLEXPRESS;Initial Catalog=PayrollSystem;Integrated Security=SSPI;Persist Security Info=True

    is not working Properly

    showing me this error:

    Loading DB....
    SQL Server Network Interfaces: Error Locating Server/Instance Specified [xFFFFFFFF].
    ERROR: database unavailable.......retry in 15 sec.

     

    Friday, May 14, 2010 9:44 AM

Answers

  • Hi,

    To troubleshoot the SQL Server connectivity issue, try the following common steps. If you connect to the server locally, just see the step 5 and 6.
    1. Check Network:
    Make sure the Network is workable and stable when you connect to SQL Server on a remote machine.  You can test the Network connection using the PING grogram:
    ping <Server Name>

    2. Enable remote connections for SQL Server:
    For both SQL server 2005 and SQL Server 2008:
    a) In SQL Server Configuration Manager, expand SQL Server Network Configuration, and then click Protocols for <instancename>.
    b) In the details pane, right-click one of the available protocols, and then click Properties.
    c) To enable the TCP/IP protocol (or named pipes) for remote connections, set the Enabled box to Yes.
    For SQL Server 2005:
    a) Open SQL Server Surface Area Configuration.
    b) On the SQL Server 2005 Surface Area Configuration page, click Surface Area Configuration for Services and Connections.
    c) On the Surface Area Configuration for Services and Connections page, expand Database Engine, click Remote Connections, click Local and remote connections, click the option including using TCP/IP protocol to enable for your environment, and then click Apply.

    3. Enable the SQL Server Browser service:
    If you connect to a named instance, make sure the SQL Server Browser service by using SQL Server Configuration Manager is enable or specify the TCP port when connecting to it.

    4. Create an exception for SQL Server in Windows Firewall:
    If firewall is enabled on the server, you need to put TCP port number of the instance, such as 1433 for the default instance. Then add UDP 1434 for SQL Server Browser Service.
    http://technet.microsoft.com/en-us/library/ms175043.aspx

    5. Check the server name you used:
    For a named instance, you need to type computer name\instance name. For a default server, you only need to type computer name.

    6. Make sure PayrollSystem is available in your SQL Server instance.

    If there are any more problems, please let me know.
    Thanks.


    ***Xiao Min Tan***Microsoft Online Community***
    Tuesday, May 18, 2010 3:16 AM

All replies

  • Hello,

    That's not a query, that's a connection string. Does it work if you change it to "Initial Catalog=master"?

    Please check the state of the database "PayrollSystem" in SSMS (Management Studio). May the database is in recovery mode or there are some other problems with it


    Olaf Helper ----------- * cogito ergo sum * errare humanum est * quote erat demonstrandum * Wenn ich denke, ist das ein Fehler und das beweise ich täglich http://olafhelper.over-blog.de
    Friday, May 14, 2010 11:04 AM
  • Hi Olaf

    Sorry to write as a Query.

    this is my full Connection String which i wright in M2SYS BioPlugIn Server

     

    Provider=SQLNCLI10.1;Data Source='HITESH-PC\SQLEXPRESS';Initial Catalog='PayrollSystem';Integrated Security=SSPI;Persist Security Info=True

    till database is not connected!

    Loading DB....
    SQL Server Network Interfaces: Error Locating Server/Instance Specified [xFFFFFFFF].
    ERROR: database unavailable.......retry in 15 sec.

     

     

    Friday, May 14, 2010 11:40 AM
  • Did you tried + check, what I wrote before?
    Olaf Helper ----------- * cogito ergo sum * errare humanum est * quote erat demonstrandum * Wenn ich denke, ist das ein Fehler und das beweise ich täglich http://olafhelper.over-blog.de
    Friday, May 14, 2010 11:45 AM
  • Hi,

    To troubleshoot the SQL Server connectivity issue, try the following common steps. If you connect to the server locally, just see the step 5 and 6.
    1. Check Network:
    Make sure the Network is workable and stable when you connect to SQL Server on a remote machine.  You can test the Network connection using the PING grogram:
    ping <Server Name>

    2. Enable remote connections for SQL Server:
    For both SQL server 2005 and SQL Server 2008:
    a) In SQL Server Configuration Manager, expand SQL Server Network Configuration, and then click Protocols for <instancename>.
    b) In the details pane, right-click one of the available protocols, and then click Properties.
    c) To enable the TCP/IP protocol (or named pipes) for remote connections, set the Enabled box to Yes.
    For SQL Server 2005:
    a) Open SQL Server Surface Area Configuration.
    b) On the SQL Server 2005 Surface Area Configuration page, click Surface Area Configuration for Services and Connections.
    c) On the Surface Area Configuration for Services and Connections page, expand Database Engine, click Remote Connections, click Local and remote connections, click the option including using TCP/IP protocol to enable for your environment, and then click Apply.

    3. Enable the SQL Server Browser service:
    If you connect to a named instance, make sure the SQL Server Browser service by using SQL Server Configuration Manager is enable or specify the TCP port when connecting to it.

    4. Create an exception for SQL Server in Windows Firewall:
    If firewall is enabled on the server, you need to put TCP port number of the instance, such as 1433 for the default instance. Then add UDP 1434 for SQL Server Browser Service.
    http://technet.microsoft.com/en-us/library/ms175043.aspx

    5. Check the server name you used:
    For a named instance, you need to type computer name\instance name. For a default server, you only need to type computer name.

    6. Make sure PayrollSystem is available in your SQL Server instance.

    If there are any more problems, please let me know.
    Thanks.


    ***Xiao Min Tan***Microsoft Online Community***
    Tuesday, May 18, 2010 3:16 AM