none
VCLibs package clash on AppX Sideloading RRS feed

  • Question

  • Is anyone else getting this issue? We're seeing it on multiple devices and can't work around it. The package with the same identity is used by a ton of other apps on most Win8 devices (e.g. the videos app, music app, etc.)

    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CFB, The provided package is already installed, and reinstallation of the package was blocked. Check the AppXDeployment-Server event log for details. (Exception from HRESULT: 0x80073CFB)

    Deployment of package Microsoft.VCLibs.110_11.0.50522.1_x64__8wekyb3d8bbwe was blocked because the provided package has the same identity as an already-installed package but the contents are different. Increment the version number of the package to be installed, or remove the old package for every user on the system before installing this package.

    There's nothing more informative in the AppXDeploymentServer log.

    Monday, July 9, 2012 9:46 PM

Answers

  • Try removing the VCLibs directories from the Dependencies directory so it doesn't try to install them and see if it still runs.

    Tuesday, July 10, 2012 5:28 PM

All replies

  • Try removing the VCLibs directories from the Dependencies directory so it doesn't try to install them and see if it still runs.

    Tuesday, July 10, 2012 5:28 PM
  • Yes,  this works, but it doesn't resolve the issue. On some machines, the install works fine with the dependencies in place, on others the folder needs to be deleted.
    Wednesday, July 11, 2012 4:35 AM
  • Doing this results in compiler warnings and and causes WACK test fails  NOT a fix.

    Friday, August 3, 2012 12:09 AM
  • Why are you running WACK on your sideload installation? Removing the folder works around not allowing you to sideload on the RP build. It is only useful for allowing you to sideloading.

    If you want an answer as to why it works on some but not others the C++ forums are your best bet.

    Friday, August 3, 2012 9:54 PM