locked
SharePoint Designer 2010 Workflow sending old email content. RRS feed

  • Question

  • I am working a workflow in SharePoint Designer 2010.   This workflow automatically starts when there is a change to an item.  The workflow is associated to a custom list.  When the workflow is triggered it sends the email, but the email content was from several versions ago.  It is not sending the current email settings saved.  The worflow has been saved, published, and checked for errors. 

    The workflow is following the conditions and action correctly.  It does not send the current email saved.  What should I do to trouble shoot?

    I thought it could be a server delay. I have given it more than 10 minutes to update without luck.  Help.


    • Edited by MissSharePoint Thursday, August 1, 2013 4:37 PM Changing verbiage
    Thursday, August 1, 2013 4:32 PM

Answers

  • Hi,

    When you publish new version workflow, then existing workflow will be still active.  Any list items associated with that workflow will continue to use the same version.  In order to remove the old versions, go to the workflow settings and click on Remove, Block or Restore a workflow option.  The following screen appears, select the Remove option for existing workflow versions.  This will force the list item to select the new workflow.

    **Please don't forget to mark as answered and helpful

    My Recent Gallery Upload: PowerShell Script for Creating Site Collection with Host Headers

    Thursday, August 1, 2013 4:57 PM

All replies

  • Hi,

    When you publish new version workflow, then existing workflow will be still active.  Any list items associated with that workflow will continue to use the same version.  In order to remove the old versions, go to the workflow settings and click on Remove, Block or Restore a workflow option.  The following screen appears, select the Remove option for existing workflow versions.  This will force the list item to select the new workflow.

    **Please don't forget to mark as answered and helpful

    My Recent Gallery Upload: PowerShell Script for Creating Site Collection with Host Headers

    Thursday, August 1, 2013 4:57 PM
  • Hi Mokhtar - I am having the same issue where previous version of my email are being sent in the email workflow instead of the current version of the email which I have saved and published numerous times.

    I tried removing the previous versions per your suggestion above but unfortunately this did not fix the problem. Any other suggestions?

    Thanks in advance.

    Friday, September 19, 2014 12:14 AM